3

I have both swedish and english activated in GBoard, but I'm using the swedish layout so I get easy access to the letter å ä ö.

My problem is that Gboard doesn't seem to "learn" some new words. A specific example is when I'm swiping hon (swedish for her), it never suggests hon, instead it autocorrects it to jobb (swedish for work) every single time. I've erased the suggestion, I've typed h o n manually and clicked it in the top bar - I even added hon to my personal dictionary in the Gboard settings, but nothing seems to help.

It's gotten so ridiculous that I just stopped erasing and correcting it when texting some of my friends, I just informed them that if they see an oddly placed jobb, just assume I mean hon :)

On a side note - both me and one of my friends (who's using Sony's built in keyboard) seem to experience periods of our predictions going haywire and suggesting completely wrong words, or in my case often weird acronyms like DF, DT, DGV etc. This seems to last for a few days and then it gets better for few weeks. Might just be coincidental, but I'm curious if anyone else is experiencing something similar?

2

I just figured it out while trying all possible Gboard settings. Turns out that "block offensive words" was activated for some reason, and apparently the word "hon" is considered offensive in some places.

I had no idea it was an offensive word, and either way I'd have thought Gboard was clever enough not to block english offensive words when I'm in "swedish mode" (i.e. when the last word i typed was in swedish and all the suggestions it comes up with are in swedish). Turns out it doesn't care, and "hon" gets blocked either way.

0

Thank you, but the suggestion above didn't work for me since I already had the 'block offensive words' disabled. However, I found out that for Gboard to learn the words I typed, I also had to enable the 'personalized suggestions', under settings > text correction. Hope this helps :)

0

I think I found a solution for this. Write the word manually and select any emoji but don't put a space between the word and the emoji, and the word will have a red underline instead of a blue one. Tap over the word and it says ... 'add to dictionary' (like in the old days). If you write the word, space, backspace and emoji, it wont work. If you do this, then delete some of the few last letters and write them again, leave no space and insert emoji again. That worked for me. Gboard is not learning automatically but at least you don't have to be writing the words every time or adding them manually in the dictionary (well, you are actually but while you are writing the message).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.