1

I'm having issue where my bluetooth will occasionally turn off. This is an issue because I have a smartwatch that connects with bluetooth.

My SO also has a smartwatch, but doesn't have this issue. I noticed in my battery usage that Bluetooth shows up as an entry in my phone, but does not on my SO.

When I tap on bluetooth, there is an option for 'Adjust Power Use'. It's apparently set to 'Turn off bluetooth when not in use.' I can tap on this option, but all it does it take my to the Bluetooth pairing screen, which doesn't seem to have any way to change the option. I also do not have battery saver mode on. There's a variety of things that are battery optimized, but my list of apps matches my SO's phone as well, so I don't think that's an issue either.

Clearly I don't want my bluetooth to turn off, otherwise it makes my watch kind of useless. Does anyone have any ideas on how to fix the issue?

2
  • Have you tried checking logcat output? The kernel prints out all sorts of messages. Some debug info would help us track the issue. Commented Feb 14, 2017 at 16:52
  • I haven't yet, no. When it turns off is kind of random, so sitting and watching logcat isn't something I considered. Commented Feb 14, 2017 at 18:32

2 Answers 2

0

So if you go into BATTERY> : MENU> BATTERY OPTIMIZATION> and change "NOT OPTIMIZED" to "ALL APPS", you can then select each app or service you want "NOT OPTIMIZED". Try Bluetooth Midi and Bluetooth Sharing to set Not Optimized.

1
  • Unfortunately, this didn't fix the problem. Thanks for trying. Commented Mar 10, 2017 at 13:55
0

My phone had this problem, and I narrowed down the problem to be caused by the Fitbit app syncing to my Versa watch.

The "problem" was actually just a mis-configuration in Fitbit app related to the the bluetooth sync options.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .