I have an Asus EEE Transformer (not the prime) that has unreliable GPS performance. I usually just fire up Google Maps in my car and use the navigation but the tablet always gets stuck with "Searching for GPS". This can go on for over 30 minutes in which the tablet either won't get a signal at all, or might get one every once in a while, update the map, and then go back to "Searching for GPS".

I have tried the following things:

  • Done the same navigation with my Nexus One in the same car and it has no problem receiving a signal right away and finding it's location so I'm pretty sure it's not environmental conditions.
  • I tether the Transformer to my Nexus One for internet so at first I thought using the "Use wireless networks" for location was just trying to get the location from the phone but toggling the option on or off doesn't seem to make it work worse or better one way or the other.
  • The amazon reviews don't seem to indicate an overwhelming problem with the Transformer with GPS.
  • I have tried the tips in this forum thread on the transformer forums.
  • I've tried installing GPSfix and using that tool but it doesn't seem to help.
  • Android version is 3.2.1, GPS version is 5.5.8, and Build # is: HTK.US_epad-

So far the only reliable means to get the GPS working seems to be to shutdown the tablet and fire it up again, at which point the GPS and Google Navigation works right away, which leads me to believe that it's a software or configuration problem rather than a hardware issue.

  • I have tried it with my Asus TF without any problems. It took about two minutes to get a GPS fix but it worked. What firmware version do you have? Commented Dec 14, 2011 at 15:35

2 Answers 2


It definitely is a software configuration. There are 2 possible reasons for this problem:

  1. Servers its contacting - When Google Maps on your tablet/phone contacts the GPS satellites, its done through a special set of servers. Sometimes, the manufacturer might have set the system to connect to a set of particularly busy servers. It has been shown that connecting to other servers with lower traffic can give dramatically faster lock on times.
  2. Possible bug in the initial configuration - when the manufacturer was setting up the initial build configuration, an unintended bug could have been introduced.

The solution to both can be done I believe through a simple fix in the gps.conf file but that would require root access. When I was running the stock firmware on my Asus Transformer, I was having the same problem. Now I am running a Custom ROM and I have no troubles with lock on in Google Maps.


Perhaps this was the problem? (from the forum thread you posted):

Originally Posted by prbgd
I am totally confused now. I just got confirmation from ASUS a few days ago. The tech person there said the GPS (US model) will not work if there is no WiFi. This is a firmware issue. It may be fixed in next firmware update.

Update: after the latest firmware upgrade today, GPS is working great now even without WiFi.

If that wasn't the problem: sometimes when I use my android device without cell signal it can take quite a while to get a GPS fix. I think it might be a combination of it using cell towers to improve GPS fix time, and having a connection to the internet to download GPS assistance data.

If you do have an internet connection when you're trying to get a GPS fix, the GPS Status & Toolbox app will let you download GPS assistance data, which could possibly improve your fix time. Just install the app, open it up, go to Menu --> Tools --> Manage A-GPS state --> Download.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .