4

With my new Moto E3, every time I open Clock application (to enable some alarm) I see a message:

Default alarm ringtone is silent [Change]

When I tap on Change I'm redirected to Sounds & notification section of Settings, where I can only see Phone ringtone and Default notification ringtone. Both set (not silent). As for alarm I can only see alarm volume (not ringtone) which is also around half (50%) and thus not silent as well.

When I open settings of Clock application itself, I can see a cool set of nice settings, but -- again -- nothing around default (or not default) alarm ringtone.

How can I set default alarm ringtone or otherwise get rid if this a bit annoying reminder?

I've been out of "Android world" for around two years or so. Last version I've used was 4.3.5, but I can hardly recall something like default alarm ringtone. If I'm not mistaken, there was default tone for notifications and default ringtone, but alarm tone was always set per each alarm separately.

BTW: Since this is a system-level notification, I assume that using 3rd party app won't solve this.

  • This may help android.stackexchange.com/q/168749/131553 – beeshyams Feb 17 '17 at 16:16
  • @beeshyams I am aware of this answer and even linked it in the question. It answers how to setup own alarm tone. I'm able to do this myself. I'm asking how to setup a default alarm tone or get rid to an annoying message that keeps poping and keeps claiming that my alarm ringtone is silenced. – trejder Feb 18 '17 at 16:54
  • Thank you, all, for your answers. It seems it was some kind of weird bug. After one of recent system updates problem no longer exists, event though I did nothing to prevent it. I think this question should stay there, because it includes a valuable suggestions when the very same problem would appear in future based on some other problem. – trejder Jan 12 '18 at 7:45
3

Assuming Moto is using a near-AOSP clock app... When you have an alarm in the list (enabled or not), you should be able to set its ringtone individually. Setting one will make alarms created in the future use that ringtone by default.

  • Unfortunately this is not a solution. I've followed these steps even before posting here. I made my first alarm with custom ringtone and -- as I wrote -- each newly added one already had the same one preselected. Thus, I thought that this is my "default alarm ringtone". Unfortunately, this annoying message keeps appearing every time I open Clock application. – trejder Feb 18 '17 at 16:52
  • So are you sure the alarm volume is not silent? The only occasion I see the alarm app complain about silence is about the volume, not the ringtone. – Andy Yan Feb 19 '17 at 0:07
  • I'm 99.99% sure (I never say that I'm 100% sure) that it is not. If it would be silent I may have some troubles past week around not getting up to work! :> However, I can share a screen shot, if you need to be more certain. The only thing that comes to my mind is that A6.0 somehow analyses volume of MP3 file used as ringtone and that check fails resulting in Android claiming that may default / the only used ringtone is silent. But, this sounds a little bit like a conspiracy theory, right? – trejder Feb 19 '17 at 13:59
  • I also use external media files as my alarm tone, but it never complained to me even when I deleted the file (resulting in empty ringtone) - weird indeed. I'll leave this here for whoever deem this meaningful, but still, sorry for not being able to truly answer your question. – Andy Yan Feb 19 '17 at 14:42
3

Go through all of your alarms, including inactive ones, and see if you have "Default Ringtone (Unknown)" set for any. If so, change the ringtone to your custom one or a preset, or delete the alarm entirely.

When making any new alarms, it should default to the last one you used... but just make sure to avoid "Default Alarm Sound." (For some reason it calls it the Default Alarm Sound in the drop down menu, but the Default Ringtone after it is selected).

I am not sure of the root cause, but this is what removed the same message for me (it was hiding on an inactive alarm). Hope it works for you too!

3

Answer is - use "ES Explorer"

Very strange, but "System settings" have only Ringtone and Notification, and no Alarm-clock sound. I think it is a bug. Maybe that setting should be in Clock app, but it also no.

Steps:

  • Play any music file you would like to set as default ringtone for the alarm in ES Media Player
  • Click three dot button [:] in top right corner
  • Select Set ringtone
  • Now set ringtone dialogue will open. Choose Set alarm
  • Now open Clock app. You should not see the warning
1

Copy your ringtone file to the Alarms folder in your internal storage using a file manager. Now you will see that ringtone file in the Default alarm ringtone list in Settings -> Sounds.

  • You mean to copy any alarm from "Alarms" folder to the root folder of SD Card / storage? Why would Clock app look for default alarm in a root folder, if it has "Alarms" folder designated for this feature? – trejder Apr 24 '18 at 8:05
  • @trejder I think he means copy your ringtone file to the Alarms folder – LyricWulf May 7 '18 at 4:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.