0

I'm using Tasker to open an app at certain time and state. I wanna open the Run log menu of Tasker at the end of the app launching task.

I know that's no need to flash on screen this log but when I tried, I haven't found a way. I can only open tasker but not launch a subordinate intent of this app.

Any help about this basic programming question will be appreciated.

Tnx in advance!

This is the description of the Tasker Manifest.xml:

0

Provided that you have root access, you can use this command to launch the Run Log window:

am start -n net.dinglisch.android.tasker/.RunLog

RunLog activity, without root access however, fails to launch and throws the error:

Permission Denial: startActivity asks to run as user -2 but is calling from user 0; this requires android.permission.INTERACT_ACROSS_USERS_FULL

Perhaps the following attribute, as mentioned in the manifest, is the cause of the issue.

android:exported="false"
  • Hi Firelord! Tnx. I tried lot of commands. First using always --user 0 permission to access all users. The RunLog intent doesn't have the dot in its name so I didn't get the result of open it. I'll try your solution. Tnx again – Nicola Al. Feb 18 '17 at 11:20
  • Unknown command – Nicola Al. Feb 18 '17 at 11:29
  • If you're using a terminal app, then the correct command is: su -c 'am start -n net.dinglisch.android.tasker/.RunLog' (note that root access is needed). If you're using Tasker and want to run this command from inside it for automation, then try Run Shell -> Command: am start -n net.dinglisch.android.tasker/.RunLog, check Root. – Firelord Feb 18 '17 at 18:34
  • 1
    I solved the problem. The package is the name of the activity. In this case .taskerm instead of .tasker – Nicola Al. Feb 18 '17 at 18:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.