1

I have a problem where the repacked system.img does not work.

My target device is : DOOGEE X5pro which uses MT6735M chip.

I am using this custom ROM. http://www.needrom.com/download/r16-android-6-0/

The original files from this custom ROM works fine with the device.

I wanted to change something in the system.img and the following is what I did.

$ simg2img system.img system.raw
$ mkdir tempsys
$ sudo mount -t ext4 -o loop system.raw tempsys
$ cd tempsys

Here I made one change. I didn't like the camera shutter sound so I simply deleted the 'camer_shutter.ogg' file in tempsys/media/audio/ui.

$ cd ..
$ tune2fs -l system.raw

here i check that "Block count : 390111", "Block size: 4096". I multiplied these two values and got "1,597,894,656".

$ sudo make_ext4 -a system -l 1597894656 -s sys3.img tempsys

BTW the permission of the sys3.img is as below:

$ ls -l
-rw-r--r--   1 chadrick chadrick 1327287648  2월 18 16:09 sys3.img

I'm not sure if the permission of the system.img file matters before flashing it to the phone. I shall proceed just as it is.

After flashing it, it is stuck at the boot logo. I guess while the device succeeded upto loading the 'boot.img' but it failed to properly deal with 'system.img'.

Apparently, could someone point out some things that I may have missed?

BTW, I did the same repack operation WITHOUT modifying any contents in with system.raw file. The repacked system.img still didn't work.

  • Doubts: permission fault inside the repacked image. Are you able to obtain a logcat, or does it not even proceed to bootanimation? – Andy Yan Feb 18 '17 at 11:54
  • @Andy Yan It doesn't even proceed to the bootanimation. I haven't tried the logcat method. But I have tried adb device to see if I can get the adb shell. However, it was described as unauthorized and adb shell didn't work. – kwagjj Feb 18 '17 at 12:54
  • Yeah that definitely means logcat isn't possible. I don't have more ideas; wait for someone else.. – Andy Yan Feb 18 '17 at 13:46
  • If you wanted to turn off shutter sound you could rename it from file manager if you have root, maybe even don't need root. – Једноруки Крстивоје Feb 18 '17 at 14:42
  • 1
    @ЈеднорукиКрстивоје thanks for the suggestion. But my main quest is trying to find out why my custom packed system.img doesn't work. – kwagjj Feb 18 '17 at 15:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.