4

How can I remove contacts from accounts I don't sync with anymore? Without being afraid of removing them from the "source" exchange account now or in the future?

Background:
When installing the email synchronization with Exchange, I thought it was a good idea to also sync the contacts.

Now the internal memory of my phone is stuffed with thousands of contacts I don't really need. It seems I cannot move them to the SD card, so I want them gone.

When I stop the synchronization (only contacts) with exchange, the contacts are not automatically removed.

I'm a bit afraid that if I remove them manually, and click or accidentally enable the sync, the contact will also be removed from my exchange contacts list, that is linked to my companies contacts list.

BTW: I know some Java, so if necessary I can develop an app to do this.

3

There's 2 slightly different solutions.

  • Log onto your corporate mail account using Outlook Web Access. Go to the account settings, i.e. the options link. Under that, select Phone, and delete your phone profile from there. Now delete & recreate the Exchange account on your phone, and this time don't choose to sync contacts.

  • Exchange has a corporate addressbook or directory, and a local addressbook for your own personal contacts. Get rid of the locally saved contacts in your Exchange addressbook, so that on the next sync they'll similarly be culled from the phone. You can always look them up in the corporate directory, and Android can also perform a lookup against the directory for contacts that aren't stored locally. This of course assumes that you don't actually need so many contacts on hand in your local addressbook, or that these are all company contacts and not external business contacts.

3

With Android 6, this is still an issue. You can remove the contacts by clearing the data from your "Contacts Storage" system app, but this will unfortunately also remove any locally stored contacts. If you use another account for your contacts sync that runs after deleting the contacts data, this might be a solution for you. I've written a blog post with detailed instructions.

  • Also notice that it'll remove the call logs – Amer Sawan Nov 30 '16 at 8:46
2

Step 1- Be sure sync is on for your other contacts (Google, for example) and that it has been synced so you don't delete contacts you've added to your phone as well!

Step 2- De-active contact sync for your Exchange account:

Settings > Accounts > Exchange > [Your Account] > Contacts to Off

Step 3- Clear the previously synced contacts by clearing the data of the "Contacts Storage" app:

Settings > Apps > All (select: Show System) > Contacts Storage > Clear Data

  • that worked for me. Still issue on 8.1 – TiloBunt Apr 10 '18 at 2:05
1

Another possibility is to hide the account in your address book/contacts on your phone. Disclaimer - not all contact apps support this though.

On my phone, when I go into contacts and click the menu button, one of the menus is Display Options. This then lets me hide or show contacts for specific accounts (ie. google, facebook, twitter, etc.). If i turn off a particular account in here, it does not show any of those contacts in my address book.

1

I faced the same problem when I configured the corporate account in my phone. Then I removed the account by going to Settings->Accounts and re added it. While re-adding I unchecked sync contacts, sync calendar, sync email and Activated the account. Now the problem is no more.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.