0

So I have this 4.4.2 Allview V1 Viper L aka Gionee Pioneer P6, with root (rooted using KingRoot) and I'm trying to install TWRP/CWM recovery (from what I read here I can install whichever I want) on it to flash a custom ROM.

I have another identical device with CWM recovery and the custom ROM fully functional, but I got help from someone with the CWM recovery. I decided to try TWRP on the other device, but I have a problem.

I have USB Debugging activated from Developer Tools menu, but when I connect it to my PC, it doesn't install it properly. Opening Device manager, I can only see a difference when I connect it to my PC in Disk Drives, where there is ALLVIEW V1_Viper_L USB DEVICE and another copy of it, and in Portable Devices 2 things appear upon connection: G:/ and H:/ - that's it. No Android ADB Interface as it should have.

I have the latest version of Android SDK on my PC, with SDK tools installed. When I run the tool from the link above, Easy Magic TWRP installer, I get stuck at "Please plug in your device..." where I get right after: ADB shell not working.

I installed Universal ADB driver, I restarted the device, I restarted the PC, uninstalled and reinstalled the devices created in Device Manager after I connected the android to PC, I tried to update those drivers, I checked and un-checked USB debugging but nothing. I don't know what is wrong. I would gladly appreciate your help.

  • Try turning from MTP to PTP, should install extra divers then try adb devices from the terminal – esQmo_ Feb 18 '17 at 16:50
  • You need VCOM and CDC drivers to get it detected (as it's a Mediatek device) – esQmo_ Feb 18 '17 at 16:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.