I am new to the development community and have started to learn about building Android from source. I've successfully built AOSP from source for my Nexus 6P (aosp_angler-userdebug, android-7.1.1_r14). $make runs fine and I can install system.img and boot.img via fastboot and all is well.

However, the .zip made from $make updatepackage fails when I try to flash it in TWPR, throwing an error Failed to install, invalid zip file format!

After doing some research I noted that $make updatepackage isn't producing a META-INF folder. When I run $make dist, META-INF is created and I can then $./build/tools/releasetools/ota_from_target_files.zip out/target/dist/ota_update.zip, but that ota_update.zip fails with the same error message in TWRP.

  • AFAIK AOSP doesn't natively have a way to package it into a functional flashable zip, that part is what 3rd-party ROMs do in their own ways (they should have a script or sth). – Andy Yan Feb 21 '17 at 0:24
  • Thanks Andy. That does seem to be the case. Most have a META-INF and an AnyKernel (or similar) scrip to make things work. It seems like the ota zips are fore side loading. – savagezen Feb 21 '17 at 20:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.