2

I must have missed something, but I can't get push notifications working for the Slack app on my Android phone.

In the settings of the app, I've set the Send me push notifications for option to Activity of any kind, with a Push timing of As quickly as possible. I also deactivated the Do not disturb feature just to be sure.

The Slack app is authorized to send me notifications in the OS settings.

What did I forget? Is there a hidden option in the Slack web application that I'm not aware of?

0
1

You might have different settings for each channel, so that the channel you are testing with, does not send mobile notifications.

With a channel selected in the sidebar, click the Notifications icon (the bell), and check the settings for the channel you are viewing:

Slack notifications dropdown

In the Mobile push notifications section, make sure you have not selected Nothing. And make sure you have not checked the Mute this channel option:

Slack - Channel notification settings

3
  • I just checked every channel, everything is set to Activity of any kind and the Mute this channel option is never checked, so the issue comes from somewhere else
    – Victor T.
    Feb 21 '17 at 12:42
  • If so, it looks like this is an Android problem, and you're probably better off posting your question at Android Enthusiasts
    – Vidar S. Ramdal
    Feb 21 '17 at 13:33
  • The fact is that push notifications on the other apps work fine (facebook, gmail, whatsapp...), the problem is only focused on Slack. As I said, in the Applications settings of Android, the Slack app is authorized to notify me. Is there another option to be aware of?
    – Victor T.
    Feb 22 '17 at 12:07
1

It is a Huawei related issue. The OS is configured to optimize battery use, and therefore forbids Slack to run when the phone is deactivated. For a reason I don't know, some applications are, as soon as they are installed, allowed to run in the background, that's why I got notifications from them (facebook, gmail, whatsapp, snapchat, etc.)

Here is a copy/paste of the procedure to fix the issue (source) :

Step 1: Go to settings --> advanced settings --> battery manager --> protected apps, then find the app you want to see notifications from, and protect it. This is "whitelisting" the app so Huawei's overeager software doesn't shut it down for no reason.

Step 2: Go to settings --> apps --> advanced --> ignore battery optimizations, then find the app and ignore it. Don't be tricked by the misleading wording, "ignoring" the app actually means to let it run, because you're telling the battery optimization function, aka Doze, to "ignore" that app.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.