1

I have a oneplus one which had CM 13 installed on it. The recovery is TWRP. Last day I tried to install Kali Nethunter ROM on the same from recovery. However things got messy and the phone didn't boot. To make things worse, I by mistake wiped everything on the device.

So I now have A device with NO OS and NO Data.

Then I booted the device to recovery and tried to use sideload. However the device wasn't getting detected on my laptop. Following commands resulted no positive results.

adb devices [no devices connected]
adb push [failed]
adb sideload [failed]

Since the device is not even getting detected as an unknown device in the USB port, I tried installing the universal adb driver available. That also didn't help.

What could I be doing wrong?

0

You can flash the phone in fastboot mode.

  1. First you need to unlock the bootloader (if it wasn't done before):

    • Power off your phone then boot into fastboot mode with power button + volume up button.

    • Connect your phone to your PC via usb cable.

    • Open a command prompt

    • Check your fastboot connection by issuing this command: fastboot devices It should return your device serial number, if not you need to make sure your drivers are installed correctly.

    • Once you've confirmed your fastboot connection issue this command:

    fastboot oem unlock

    The device will now go through the automated unlocking process, just let it do its things.

    • Done

      1. Flashing thee Cyanogen OS Fastboot Images
    • Download the latest stock images

    • Reboot your device into Fastboot Mode (power + volume up) and connect your phone to your PC via usb cable.

    • Unzip the file you downloaded and put its contents into your fastboot folder.

    • Open a command prompt.

    • Issue these fastboot commands (Every line ends by hitting enter):

    fastboot flash modem NON-HLOS.bin

    fastboot flash sbl1 sbl1.mbn

    fastboot flash dbi sdi.mbn

    fastboot flash aboot emmc_appsboot.mbn

    fastboot flash rpm rpm.mbn

    fastboot flash tz tz.mbn

    fastboot flash LOGO logo.bin

    fastboot flash oppostanvbk static_nvbk.bin

    fastboot flash boot boot.img

    fastboot flash cache cache.img

    fastboot flash recovery recovery.img

    fastboot flash system system.img

    fastboot flash userdata userdata_64G.img

or  

fastboot flash userdata userdata.img 

(if you have the 16gb model)

  • Reboot your device with this command:

    fastboot reboot

  • Done.

Let me know if something goea wrong.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.