I uninstalled the King Root app after rooting my phone. Now my system isn't working correctly.


  • When going in Settings->Storage it says "System Used : 16.00GB" (All my storage). I do not have an SD card and because of this I can't take pictures or download files.
  • When connecting my phone to my computer (Ubuntu 16.10) a folder pops up but it is empty.

I tried reinstalling KingRoot but I can't download the app since I have no storage space.

I'm willing to do anything (ex. reinstall os) if necessary. Please just explain how.

Phone model: BLU studio M HD

Thanks in advance

  • Have you tried a factory reset? – Ethan Z Feb 22 '17 at 23:56
  • @EthanZ the factory reset worked – staad Feb 25 '17 at 18:24

As @EthanZ said the factory reset solved the problem. Press the up volume key and power key when the device is powered of to get to the boot menu. Select Factory Reset. Done! Thanks EthanZ.

  • While a factory reset isn't always an ideal option, it's usually easier than identifying the root issue. – Ethan Z Feb 25 '17 at 18:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.