1

I'm having an issue where I can't access pretty much any of my google services on my Samsung Galaxy S7 edge (running Android 6.0.1 currently). I don't have general internet connectivity issues as my wifi and mobile connections are fine and other apps are running without issue.

My google account information doesn't seem to be the problem as I've successfully signed into the account on my PC and even on my phone through my web browser, it's just the apps which are a problem.

When I try refreshing my gmail account, I get a system notification saying login failed. When I click that message, the phone tries to take me to a screen which says "Enter account information" at the top, but the rest of the screen is blank white.

I also have another system notification saying Account Action Required for my gmail account but when I click that one, it takes me to a Google Play screen where it says "Checking info" but immediately closes. When I go to Google Play manually, I get the same screen then it asks me to choose an account. My existing account is listed but when I select it, I just keep getting taken back to the same screen asking me to select an account. If I choose add account, I get an error message stating "Couldn't sign in. There was a problem connecting to accounts.google.com"

I've done some fairly extensive research already online and tried several steps from various sites, none of which have worked. Listed below is what I've seen and tried:

  1. Verified 2 step authorization is not active
  2. Cleared Cache and Data from Google Play and Google Play Services. Tried disabling Google Play and reinstalling the factory version.
  3. Checked Date and Time settings and they are set to automatic. Turn them off then back on again for good measure.
  4. Downloaded ES File Explorer and tried checking the Host file. Apparently the phone is not rooted and I was unable to figure out how to enable rooting even after enabling Developer Options.
  5. Downloaded and installed what I believe to be the newest APK for Google Play Services.
  6. Plenty of rebooting along the way.

Any help would be greatly appreciated as I'm really at a loss to the cause of this issue and I'm not finding anything more to try online. Thanks!

0

It seems like everyone was logged out of their phones yesterday, possibly for safety due to a widespread caching bug.

Have you tried removing your Google account, then adding it back in?

Settings > General > Accounts. Tap your Google account, then the overflow button, then select Remove.

Re-add the account from that same screen.

0

So to preface this: I actually had this happen to me all the time, and I eventually was able to purposefully recreate it and figure out what was going on. This was my solution; hopefully it helps you, too.

That said, my problem was in fact with my hosts file. Since you said you weren't able to access yours, I believe that might still be the case. Rather than attempt to root your phone immediately, my first suggestion is to look at any apps you might have recently installed and used that may have caused the problem. In particular, ad blockers often try to circumvent ads by redirecting web addresses to localhost. Another possible redirect is billing and license verification. If you've tried using an app for any of those purposes, see if you can undo the changes in said app.

Next up, if that's not the problem: rooting. Not an easy process and, because I probably legally need to, I AM NOT RESPONSIBLE FOR ANY ILL EFFECTS DUE TO ATTEMPTING TO ROOT YOUR PHONE. ROOTING IS DANGEROUS AND WILL VOID YOUR WARRANTY. PROCEED AT YOUR OWN RISK. That out of the way, the most important thing to remember when rooting your phone is to get software that matches your exact phone model and carrier. If it doesn't, just don't. You'll save yourself a lot of headache. ...there are a million and a half guides on rooting, so I won't reinvent the wheel here, but in general, the process is: find a custom recovery for your model/carrier > flash custom recovery with a computer program called Odin > download su.zip > flash su.zip with custom recovery. Some devices may require a preliminary step called unlocking the bootloader... Google around for your phone, you can figure it out... Now on to the fix!

My particular problem was a redirect of android.clients.google.com. It sounds like your problem might be similar (accounts.google.com). Once you're rooted, use ES File Explorer to open either /etc/hosts or /system/etc/hosts in text edit mode. Search for the suspect line, and delete the whole line! It should look something like:

127.0.0.1 accounts.google.com

If your hosts file is excessively large and you can't search within it, you can actually delete it and replace it with a file named hosts with a single line in it:

127.0.0.1 localhost

Everything should work thereafter. You can even unroot from the settings of the SuperSU app if you want. Hope I was able to help!

0

Check your mobile date and time And secondly check if BACKGROUND DATA is turned OFF.it too restricts any Google app from working.it will be indicated by a triangle icon in the notification area

  • Thanks for the help! I checked the date and time settings a while ago as I had a similar problem with my Samsung tablet a while ago. I hadn't checked the restriction of Background Data but I have now confirmed that it was not restricted. If you have any other ideas, I certainly appreciate your time. Thanks again! – Stephen Birmingham Feb 27 '17 at 3:52
0

Go through following steps: 1.Settings. 2.Accounts. 3.Delete Google accound if exists. 4.Add new Google Account. 5.Restart Your Phone.

  • I appreciate the help! Unfortunately, this didn't seem to work for me. Now when trying to add any account (my existing account or a new one), I get the error message "There was a problem connecting to accounts.google.com". – Stephen Birmingham Feb 27 '17 at 3:50

Not the answer you're looking for? Browse other questions tagged or ask your own question.