Here's what happened:

One morning, my phone started rebooting once or twice on its own. I thought it was the power button, but then it got stuck at the boot animation logo. I've let it run like 3 hours, so I don't think it's some long update running.

When I reboot to recovery, it shows a dead droid with a red warning sign. dead droid

Only thing that still works is the fastboot. When I try to flash a new recovery (I tried twrp or cwm) with:

sudo ./fastboot flash recovery recovery.img

the command seems to run fine, but when I reboot to recovery, I'm still stuck with the dead droid with a red warning sign.

I would like to get my data back if possible (especially my files) so I didn't try flashing the whole stock rom. But if that's the only last thing to do, I'll give it a try.

So, What else can I do ? Why can't I even get the recovery working ?

TLDR; Nexus 5 bricked, bootloop, recovery HS, fastboot works; what do ?

2 Answers 2


My phone was stuck in a boot loop too for no apparent reason. I was driving to work and suddenly the phone started rebooting. 3.5 hours later it ran out of battery. I have no idea why, but this is how I got it back to life...

I use linux ubuntu so I was able to get the developer tools:

sudo apt-get install adb android-sdk
sudo apt-get update; sudo apt-get upgrade

I also downloaded the latest image from google from:


To recover the phone I performed the following operations from the bash shell:

1. Unlock the phone

fastboot oem unlock

me@ubuntu:~/Downloads/hammerhead-m4b30z$ fastboot oem unlock
< waiting for any device >
OKAY [ 47.200s]
finished. total time: 47.200s

This launches a prompt saying that it's waiting for devices. I then connect the dead phone using a regular USB cable.

The android device presents a menu saying asking if I'm sure I want to unlock the device and accept that the warranty might be void. As warranty on the Nexus 5 is void anyway, I can't see any harm in progressing.

2. Install the image file

Next I unzip the downloaded image file and cd into the folder:

me@ubuntu:~/Downloads/hammerhead-m4b30z$ ll
total 609328
drwxr-x--- 2 me me      4096 Dec  7  2016 ./
drwxr-xr-x 4 me me      4096 Oct 21 16:20 ../
-rw-r----- 1 me me   3199188 Dec  7  2016 bootloader-hammerhead-hhz20h.img
-rw-r----- 1 me me       974 Dec  7  2016 flash-all.bat
-rwxr-x--x 1 me me       845 Dec  7  2016 flash-all.sh*
-rwxr-x--x 1 me me       798 Dec  7  2016 flash-base.s
-rw-r----- 1 me me 574089971 Dec  7  2016 image-hammerhead-m4b30z.zip
-rw-r----- 1 me me  46581248 Dec  7  2016 radio-hammerhead-m8974a-

As the phone is unlocked, I can issue the flash command from here:

sh flash-all.sh

As the script executes I see the following messages:

me@ubuntu:~/Downloads/hammerhead-m4b30z$ sh flash-all.sh 
target reported max download size of 1073741824 bytes
sending 'bootloader' (3124 KB)...
OKAY [  0.291s]
writing 'bootloader'...
OKAY [  0.516s]
finished. total time: 0.807s
rebooting into bootloader...
OKAY [  0.062s]
finished. total time: 0.112s
target reported max download size of 1073741824 bytes
sending 'radio' (45489 KB)...
OKAY [  1.547s]
writing 'radio'...
OKAY [  3.123s]
finished. total time: 4.670s
rebooting into bootloader...
OKAY [  0.000s]
finished. total time: 0.050s
target reported max download size of 1073741824 bytes
archive does not contain 'boot.sig'
archive does not contain 'recovery.sig'
archive does not contain 'system.sig'
archive does not contain 'vendor.img'
wiping userdata...
Creating filesystem with parameters:
    Size: 13725835264
    Block size: 4096
    Blocks per group: 32768
    Inodes per group: 8144
    Inode size: 256
    Journal blocks: 32768
    Blocks: 3351034
    Block groups: 103
    Reserved block group size: 823
Created filesystem with 11/838832 inodes and 93654/3351034 blocks
wiping cache...
Creating filesystem with parameters:
    Size: 734003200
    Block size: 4096
    Blocks per group: 32768
    Inodes per group: 7472
    Inode size: 256
    Journal blocks: 2800
    Blocks: 179200
    Block groups: 6
    Reserved block group size: 47
Created filesystem with 11/44832 inodes and 5813/179200 blocks
Bootloader Version...: HHZ20h
Baseband Version.....: M8974A-
Serial Number........: 02c6bc76215fcd2d
checking product...
OKAY [  0.100s]
checking version-bootloader...
OKAY [  0.100s]
checking version-baseband...
OKAY [  0.100s]
sending 'boot' (9156 KB)...
OKAY [  0.500s]
writing 'boot'...
OKAY [  0.781s]
sending 'recovery' (10014 KB)...
OKAY [  0.569s]
writing 'recovery'...
OKAY [  0.824s]
erasing 'system'...
OKAY [  1.297s]
sending 'system' (1020657 KB)...
OKAY [ 32.164s]
writing 'system'...
OKAY [ 69.195s]
erasing 'userdata'...
OKAY [  7.820s]
sending 'userdata' (137318 KB)...
OKAY [  4.511s]
writing 'userdata'...
OKAY [  9.175s]
erasing 'cache'...
OKAY [  0.628s]
sending 'cache' (13348 KB)...
OKAY [  0.630s]
writing 'cache'...
OKAY [  1.064s]

finished. total time: 130.023s

3. Welcome To Android instructions that you see on a new device.

Now it works.


This seems like a strange issue; do you remember tweaking your phone before it turned off, because a lot of tweaks like that only take effect after a reboot. I doubt that you only have access to the fastboot commands, but if so, you can run fastboot erase cache to erase the cache of your device. Let it boot for some time after running this command, because the cache needs to be "restored" after cleaning it. It is more likely that you also have access to adb, in which case you should make a full backup before deleting all partitions and re-installing the OS.

Here's a link to a program somebody made to backup files directly to the PC, and here's another thread on xda.

adb pull /system/app backup/systemapps backs up all the system apps of your phone to the systemapps folder in ADB on your PC, adb pull /data/app backup/installedapps backs up all the installed apps of your phone to the installedapps folder in ADB and adb pull can help with moving individual files.

Hope this helped!

  • I think my phone is definitely bricked now: when I try to flash anything, it would say FAILED (remote: flash write failure) after trying a factory reset. I discovered I cant boot to a recovery image without flashing it (with fastboot boot recovery.img) and it gives access to adb but that doesn't help since the thing can't flash or mount anything.
    – BiAiB
    Mar 6, 2017 at 18:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .