2

I visited a website yesterday. Today, a notification popups every time my mobile phone is rebooted, showing me that website (it is grouped under "Social digest"). However, when I click on that notification, it only takes me to Chrome but not to that website.

How to permanently remove this notification?

  • Please provide screenshots, Android version, device name and the link to the website. – Firelord Feb 27 '17 at 19:05
  • "It is grouped under 'Social digest'" I couldn't find any references on the internet if Chrome shows social digest notification instead of individual site's push notification (unless "Social Digest" is the site's name...). It might be another's app notification (or ads/malware) that redirects to the default browser instead. But considering you already accepted an answer for turning off Chrome's notification, then I guess that's not the case for you... – Andrew T. May 3 '19 at 15:35
1

Open Chrome → Settings → Site settings (under "Advanced") → Notifications and click on it.

The following screen will appear

Per-site notification setting on Chrome

If you turn off the Notifications slider, you will not get any notification from Chrome at all (from sites).

To turn off for a particular site, click on Allowed → [URL of the site] → Notifications (under "Permission") → change "Allow" to "Block".

| improve this answer | |
1

If you want to delete notifications for specific sites in the list. You have to manage in storage of application by going Android's Settings > Apps > Chrome > Storage > Manage Space > Manage.

From there, select the domain URLs that you do not want individually, which will show its "Site settings", then select the trash can next to "Usage" and select "Clear all".

| improve this answer | |
  • this answer is better – Dan Z Jan 16 at 1:13
  • i dont think it works though – Dan Z Jan 16 at 1:14
  • Im on a samsung s10. I went to storage>manage storage on bottom left> then clicked free up space and manage. not sure if clear all data is good to do. – Dan Z Jan 16 at 1:16
0

If you go to the "More info" section of the Chrome app (Android's Settings > Application Manager > Chrome), uncheck "Show notifications". This will turn off all notifications for Chrome.

| improve this answer | |
  • In the "Settings", I have "Basics" and "Advanced". In the "Basics", I have "Search engine", "Auto-fill forms" and "Save passwords". In the "Advanced", I have "Privacy", "Accessibility", "Site settings", "Date saver" and "About Chrome". I cannot find "application manager". – lanselibai Feb 28 '17 at 9:38
0

I have at last worked out how to remove notifications permanently from Chrome on Android..... Press the three dots at top right of chrome.... Go to settings... Press notifications.... Scroll all the way to the bottom and you will see an advanced button, press it...you should then see....additional settings....press this again.... Now you should find yourself in the notifications section of Chrome. You can see both Blocked and Allowed notifications and by going through the different addresses and clicking on each of the sites you wish to remove you will be given the option: Clear and Reset -press this if you want to remove the notification from your phone in its entirety.

Hope this helps.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.