I installed RUU 4.2.2 in an attempt to upgrade HBOOT to 2.16 on a HTC One S. The boot menu shows 2.16 so I guess it worked but now I have no OS.

I am trying to install a ROM (Lineage 14) but I get error messages like this

mount: failed to mount /dev/block/platform/msm_sdcc.1/
umount of /system failed: no such volume
Patching system image unconditionally...
E1001: Failed to update system image.
E:unknown command[log]
E:Erorr executing updater binary in zip '/sdcard/linea
Error flashing zip '/sdcard/lineage.zip'
Updating partition details...

If I adb shell then ls /dev/block/platform/msm_sdcc.1 I get

by-num      mmcblk0p13  mmcblk0p19  mmcblk0p24  mmcblk0p3   mmcblk0p35  mmcblk0p8
mmcblk0     mmcblk0p14  mmcblk0p2   mmcblk0p25  mmcblk0p30  mmcblk0p36  mmcblk0p9
mmcblk0p1   mmcblk0p15  mmcblk0p20  mmcblk0p26  mmcblk0p31  mmcblk0p4
mmcblk0p10  mmcblk0p16  mmcblk0p21  mmcblk0p27  mmcblk0p32  mmcblk0p5
mmcblk0p11  mmcblk0p17  mmcblk0p22  mmcblk0p28  mmcblk0p33  mmcblk0p6
mmcblk0p12  mmcblk0p18  mmcblk0p23  mmcblk0p29  mmcblk0p34  mmcblk0p7

In TWRP 2.6.1.0 I can wipe cache and Dalvik cache, Format Data and Factory Reset. If I adb shell and run mount I get

rootfs on / type rootfs (rw)
tmpfs on /dev type tmpfs (rw,nosuid,relatime,mode=755)
devpts on /dev/pts type devpts (rw,relatime,mode=600)
proc on /proc type proc (rw,relatime)
sysfs on /sys type sysfs (rw,relatime)
/dev/block/mmcblk0p34 on /cache type ext4 (rw,relatime,data=ordered)
/dev/block/mmcblk0p35 on /data type ext4 (rw,relatime,data=ordered)
/dev/block/mmcblk0p35 on /sdcard type ext4 (rw,relatime,data=ordered)

I can mount cache, data, and system from the TWRP menu, but not USB-OTG. If I go to Advanced Wipe, I see

E:Unable to mount '/usb-otg'

How do I fix these errors so I can install my OS?

  • It's a lil miraculous that I happen to check SE 10 minutes within you posting all your questions today... – Andy Yan Mar 1 '17 at 11:18
  • What exactly did you do with adb shell? I assume you created system directory with ext2,3, or 4 FS. Please help me with exact steps. I'm stuck with the same error. – Mohini Sep 5 '17 at 15:17
  • I upgraded the TWRP version from 2.7.something to 3.1.something using instructions from xda-developers.com/how-to-install-twrp The problem is solved still interested in the manual solution. do let me know how to get around it manually. – Mohini Sep 5 '17 at 15:36

Still assuming S4 variant. Your TWRP is so outdated - get the latest here. Flash through fastboot as usual.

  • Not guaranteed to solve, but I think 2.6.x isn't compatible with the new partition layout introduced in HBOOT 2.16 anyway. – Andy Yan Mar 1 '17 at 11:19
  • I have TWRP 3, still getting these and similar errors. TWRP "fix partition" tool doesn't work either. – spraff Mar 1 '17 at 16:27
  • Tried ROMs with older Android versions? See if the problem's with this particular package. – Andy Yan Mar 2 '17 at 3:15

I fixed it by going into adb shell and running mkdir, mount, and mke2fs manually.

  • Can you explain how you did? It will help users more. – Vivek Ji Aug 29 at 12:05

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.