On rebooting my Samsung Galaxy S2 (running Villain ROM 3), I got an error in the status bar "USB Storage damaged. It may need reformatting". File managers like Astro fail to open the /mnt/sdcard folder.

Things I've tried so far:

  1. Rebooting
  2. Connecting via USB cable to PC in USB debugging mode (This brings up 2 drives, but they are not mounted)
  3. Removing the external SD card and rebooting

Anyone encountered this issue before? Any suggestions?


Solved it myself after hours of Googling.

I really only needed to run error checking on the internal storage (CheckDisk) in Windows. Since I couldn't get Windows to mount the drive normally, I tried booting into ClockworkMod recovery mode and then connect USB.

Ran the error checking (Right click on drive, Properties, Tools, Error-checking), rebooted phone and voilà! Life is beautiful once again.

| improve this answer | |
  • 2
    Awesome! Don't forget to "accept" this answer so that it can act as a signpost for future readers. – ale Dec 19 '11 at 15:41

I had the same problem and I found a solution.

First, problem description: I've connected the S2 to a PC and turned on the mass storage mode. After copying the files I've selected on the phone to disconnect from pc (without unplugging the device in windows - which may cause this problem). After that I found out that both memories (sd card and 16gb usb memory) are damaged.

Solution: I have connected the phone to a pc, choose to turn on the mass storage mode. Windows found the drives but they are empty (unmounted). I selected on the phone disconnect from pc and this time I have unplugged the cards from Windows. After this my phone found the memories and start working again. I think it is a system glitch which hangs the card somewhere between mass storage mode and direct access to them.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.