1

Something went wrong when I updated my Nexus 4 (Mako) with Paranoid Android 6 via TWRP 2.8.

I formated the phone in Recovery Mode but now I unable to connect to adb to transfer new OS image in the internal memory. So, I'm stuck with a phone without operating system.

The battery loads well when connected to my debian but I can't see anything related to the phone with lsusb.

I'm definetly not an expert with TWRP, but I noticed an error when I try to start adb sideload : E:Unable to mount /usb-otg.

I'm also considering to open the device but from informations I found there is no way to extract the internal memory to flash it from my debian.

How can I debug that ? Alternatively, what are my options to send a new image to my phone ?

UPDATE 1: When I enter in fastboot mode (the screen with the android picture) I see:

FASTBOOT MODE
VARIANT - mako 8GB
HW VERSION - rev 11
BOOTLOADER VERSION - MAKOZ10o
BASEBAND VERSION - M9615A-CEFWMAZM-2.0.1700.48
CARRIER INFO - None
SIGNING - production
SECURE BOOT - enabled
LOCK STATE - unlocked

In this mode I still have nothing on lsusb or fastboot devices -l.

UPDATE 2: Here is what I see in dmesg -w | grep usb when I connect the phone :

[3416.043914] usb 3-2: new full-speed USB device number 22 using xhci_hcd
[3416.155984] usb 3-2: device descriptor read/64, error -71
[3416.371985] usb 3-2: device descriptor read/64, error -71
[3416.587946] usb 3-2: new full-speed USB device number 23 using hci_hcd
[3416.700008] usb 3-2: device descriptor read/64, error -71
[3416.915999] usb 3-2: device descriptor read/64, error -71
[3417.131964] usb 3-2: new full-speed USB device number 24 using xhci_hcd
[3417.132235] usb 3-2: Device not responding to setup address.
[3417.336256] usb 3-2: Device not responding to setup address.
[3417.539975] usb 3-2: device not accepting address 24, error -71
[3417.651994] usb 3-2: new full-speed USB device number 25 using xhci_hcd
[3417.652222] usb 3-2: Device not responding to setup address.
[3417.856035] usb 3-2: Device not responding to setup address.
[3418.060047] usb 3-2: device not accepting address 25, error -71
[3418.060149] usb usb3-port2: unable to enumerate USB device

  • How's fastboot working? – Andy Yan Mar 4 '17 at 16:19
  • fastboot devices -l gives me nothing. – Plup Mar 4 '17 at 18:09
  • Are you in fastboot mode? Don't restrict yourself inside TWRP. – Andy Yan Mar 5 '17 at 0:12
  • I updated my comment with information relative to fastboot mode. I'm definetly new with android, but don't you think I should see something in lsusb whatever mode I use ? – Plup Mar 5 '17 at 13:22
  • I updated my question with details from dmesg. Apparently something is wrong on this side. – Plup Mar 6 '17 at 12:31
0

It turned out that the communication problem on the USB bus came from a "loose" connection of in the micro USB. I succeeded to reset a factory image just leaving the phone and the connector in a particular position to keep the contact.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.