1

I have HTC One M8 GPE with Andorid 6.0 Marshmallow installed.

I used my Transcend Micro SD Card as Internal Storage / Adoptable Storage.
At morning I got the message "Transcend SD Card Missing. Reinsert This Device".

I took the card out, inserted it for many times.
Turned OFF and ON the device, etc...
Yet it seems the device won't recognize the SD Card.

If I go into Recovery Mode (I have TeamWin 3.0.01 version) in the Storage Options I can see "Transcend SD Card - Adopted Storage".
So it seems the connector, electricity wise, is working.

Now, few questions:

  1. How can I check the SD Card is working without jeopardizing the data in it?
  2. Is there a way to extract the data from the SD Card (A lot of personal data I'd like to extract)? Maybe some way to do so from the recovery menu or FastBoot mode?

All I care about now is to extract the data from my Phone.

Any assistance will be appreciated.

Thank You.

1

I guess it's either sd card dead or sd card slot faulty. However there is way to decrypt adopted sd card but if you factory reset device and wipe key you are screwed here is how to decrypt Btw try to put other sd card in your phone and see if phone is recognize it.

  • When I insert it in another Android device the device recognizes it yet says it can't access it. I guess since it is encrypted. As I wrote it seems that the recovery sees the card. Though doesn't seem I can see data since it is encrypted. Could it be that the issue is some corrupted writing and can be fixed within the Android device? – Royi Mar 7 '17 at 10:22
  • Yeah that's normal. Adopted sd card can't be used with other devices. In your case I think that android just went crazy and formating sd card would fix problem (probably). In my answer you have a link to guide how to access data on adopted sd card you'll need just linux PC, it's safest way. – Једноруки Крстивоје Mar 7 '17 at 12:35
  • OK, It seems I can easily copy data and all seems to be fine. Is there a way to fix things? How do I merge things back to the way they were? – Royi Mar 7 '17 at 15:01
  • Did you copied everything you had/need from that sd card? If yes you can try formating sd card and put it back to phone to see if it works. Did you tried other sd card with your phone, try it just know what is happening. – Једноруки Крстивоје Mar 7 '17 at 15:35
  • Hi, Yes. I copied all I needed. Won't formatting it destroy all data? I meant since it seems to be working maybe just something small is corrupted and can be fixed with something like CHKDSK or something. I'm not looking into just reuse the card as storage. I want to get the whole phone t its previous state. I will try another SD Card, yet won't that make the phone forget the current one? – Royi Mar 7 '17 at 15:45
1

Card failure rates increase significantly when used as adopted storage... It's seen in lots of devices. My guess is the card is failing.

Retrieving it is iffy at best, if the card is not defective, you are rooted, are familiar with Linux, and can follow this process which involves retrieving the encryption key and mounting the system in Linux (or making an image of it and mounting that), there is a chance of retrieving the data.

If the filesystem or card is damaged, the chances of data retrieval, even by a professional data recovery company, are as close to zero as you can get.

  • Could it happen from other reason but a failing card? Is there a way to check the card without damaging the data on Windows system? Anyway to do something like CHKDSK on Windows to the card from the recovery menu? – Royi Mar 7 '17 at 5:09
  • When I run lsblk on the terminal I see 2 Volumes (Is that the correct term?). The first is sdc -> sdc1 which is only 16MB and the other sdc->sdc2 which is 59GB and contains all data. Using the Decrypted map for sdc2 I recovered all media files. Out of curuiosity I triend working on the sdc1. Yet when I try to mount it I get the following message: "wrong fs type, bad option, bad superblock on /dev/mapper/crypt2`, missing codepage or helper program or other error". Maybe this superblock is what needed to be fixed? What can I do to fix it? – Royi Mar 7 '17 at 17:38
  • @Royi If you have retrieved the data from the data from the card successfully, then delete the partitions on the card with fdisk/gparted and insert into the phone and reformat it or format it as a single fat32 partition in the computer and reinsert into the phone. I would not reuse the card as adopted storage, it cannot be trusted at this point. You could attempt to use it as portable storage or in another device where the storage is not critical. – acejavelin Mar 7 '17 at 20:36
  • Is there a way to just tell the Camera save Videos and Photos on External SD? If that can be done all is good. Thank You. – Royi Mar 7 '17 at 20:38
  • @Royi That depends entirely on your camera app and it's permissions... You may need to give it permissions. How to - Provide WRITE PERMISSION on sd card for apps on Android Marshmallow: 1. Backup File - packages.xml in /data/system folder 2. Open File - in QuickEdit app 3. Search - for app name 4. Paste - <item name="android.permission.WRITE_MEDIA_STORAGE" granted="true" flags="0" /> in/after <perms> tag 5. Save - by pressing back twice and confirming Yes(Grant Root permission if asks) 6. Reboot – acejavelin Mar 7 '17 at 20:41
0

I post a workaround with no data loss, no root needed, no wiping the phone : https://forums.lenovo.com/t5/MOTO-G-3rd-Gen/SD-Card-Missing-Please-Reinsert/m-p/3751841#M9407

2 steps :

  1. Plug the unrecognised SD card to the phone (Moto 3G) through an external SD Card reader and female to male Micro USB. The phone will first recognise a new usb drive and start the process to mount the drive. It will fail and the drive should disappear from the phone memory settings.
  2. Then unplug the SD card reader and simply put the SD card into its internal slot. The phone should immediatly recognise it as the "lost" SD card. Everything gets back to normal.

protected by Community Jul 16 at 17:15

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.