1

I have a Sony Z5 Compact running Nougat.

I am unable to install Facebook Messenger. When I try I get the Error Code -505.

I have tried installing using ADB with the following command:

adb install com.facebook.orca_108.0.0.10.70-51197341_minAPI21\(armeabi-v7a\)\(280,360,400,420,480,560,640dpi\)_apkmirror.com.apk

Which seems to be the latest stable version from apkmirror.com.

I get the error message:

Failed to install com.facebook.orca_108.0.0.10.70-51197341_minAPI21(armeabi-v7a)(280,360,400,420,480,560,640dpi)_apkmirror.com.apk: Failure [INSTALL_FAILED_DUPLICATE_PERMISSION: Package com.facebook.orca attempting to redeclare permission com.facebook.receiver.permission.ACCESS already owned by com.facebook.appmanager]

Is this something I have done? The phone is not rooted, nor have I unlocked the boot loader.

Apart from wiping the phone is there anything I can do to get the app installed? (I'm aware of all the 3rd clients, but I would really like to solve this problem.)

The app was installed before the upgrade to Android 7, but an update would not install.

I have done the usual steps like restarting, empty cache and data of Play Services, etc.

This is not a duplicate of How do I deal with unknown installation error code -505?, which was supposed to be solved with an upgrade to Android 5.0.2. I am running Android 7.

9
  • Good point, @wbogacz – and the answer is right on top of your list: How do I deal with unknown installation error code -505?
    – Izzy
    Mar 8 '17 at 14:24
  • 1
    @Izzy just checked the link you provided. This has no relevance to my problem. They are talking about it being fixed in 5.0.1. I am using 7.0. There is an explanation of the problem, and it's causes but no solution. Mar 8 '17 at 15:13
  • Well, it's the very same underlying cause – as you can clearly see by your error message: Package com.facebook.orca attempting to redeclare permission com.facebook.receiver.permission.ACCESS already owned by com.facebook.appmanager. So your solution would be a) to uninstall com.facebook.appmanager or b) have its developer fix the package (or c) not install com.facebook.katana). Not sure where that one originates, it's not listed on Playstore. The two packages cannot coexist if they both declare the same permission as their own.
    – Izzy
    Mar 8 '17 at 17:44
  • From what I gathered from a quick Google search, it's a builtin service mainly used to support Gear VR. Mar 8 '17 at 21:21
  • I cannot uninstall 'com.facebook.appmanager' or 'com.facebook.system'. I have disabled them but that does not help. Mar 9 '17 at 8:10
0

My girlfriend and I both Sony Xperia Z5 Compact have the same problem (Error 505) after we had updated to Android 7 Nougat. I think for most people, the problem will become public when the old Facebook app gets outdated and force an update. I was too naive to uninstall Facebook, Messenger, and Site Manager for a fresh install try, and now am only able to use these Facebook platforms on a browser. I posted the same problem in Sony Support Forum and am also surprised that such popular app errors on Android 7 result only in 1-3 problem topics at this time.

The official answer from Sony: Make a factory reset because the problem happens with an update. Not the expected answer - but seems the only solution, when the company doesn't want to fix these issues.

1
  • This is such a hassle when you start to use 2FA apps like authenticator. Is there a way to make a 'mirror' of the phone so I can wipe it clean and then get everything back the way it was quickly without having to re-login on all my apps? Mar 20 '17 at 20:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.