This morning, I turned on my mobile, which had been fully charged during the night. It displayed the usual white «Samsung Galaxy SIII Neo powered by android» thing, but then it vanished, then it reappeared, and it has been doing this throughout the day, for all I know. I tried googling, and found out about:

  • FastBoot, which is acheived by pressing Vol+,Vol-,Power all at once; this does nothing at all on my device;
  • Recovery boot, which is acheived by pressing Vol+,Power,Home all at once; this displays a small blue «RECOVERY BOOTING…» on the top-left corner, but only if the phone is connected to a charger, otherwise nothing happens;
  • Hard Reset, but this seems to be impossible, as it requires (see here) the phone to be completely off, which is, at present, simply impossible.

Removing the battery won't do anything: I tried that several times, but as soon as I put it back, it goes back to doing the above. Also, connecting to the charger makes the «Samsung Galaxy [etc]» display like 2 or 3 times longer.

What should I do about this? What is wrong with my phone?


Following @MatthewRead's comment, I tried Vol-,Power,Home. Something flashed on the screen, and then back to on-off-on-off. This is a frame of a short movie I captured with another mobile:

enter image description here

Sorry for the name of the movie showing up and hiding «Warning». I just tried Vol+ as that screen suggests, and now the screen shows up no more. One thing is sure: holding down that combination now stops it from on-off-on-off-ing, but as soon as I release, we're back there.

Update 2

I tried other key combinations, and this is what I found out:

  • Vol+ -> Recovery booting;
  • Vol+,Home -> Recovery booting;
  • Vol+,Power -> Recovery booting;
  • Vol+,Power,Home -> Recovery booting;
  • Power,Vol- -> screen above;
  • Vol-,Home -> screen above;
  • Vol-,Power,Home -> screen above;
  • Vol- -> screen above.

The last two have not always happened, but maybe I thought I was pressing when I actually wasn't. The screen says to hit Vol+ or Vol-, but none of those does anything.

Update 3

Someone suggested I scrape the battery contacts, I did it, and now the mobile seems to be working again. So this apparently saved me the trouble of flashing, though I have the firmware downloaded in case something goes wrong.

  • You should be able to do a Factory Reset from Recovery Mode. A hard reset refers to either a full power cycle (which you've done) or a Factory Reset. You might want to try other key combinations to get into Download Mode (the alternative to Fastboot used by Samsung phones) -- it's probably Vol- + Power + Home. Mar 9, 2017 at 21:29
  • @MatthewRead tried that combination. Something flashed for a few seconds, I was only able to read «Warning, a custom OS might», and then it went back to on-off-on-off.
    – MickG
    Mar 9, 2017 at 21:41
  • @MatthewRead see updates.
    – MickG
    Mar 9, 2017 at 22:06
  • Please revive the external SD card and see. I had a somewhat similar situation which got fixed by changing SD card on a different phone
    – beeshyams
    Mar 10, 2017 at 0:09
  • @beeshyams What do you mean by "revive the SD card"? Yesterday's trials were done while another device was up and running with my SD card, so that should not be the problem.
    – MickG
    Mar 10, 2017 at 9:11

3 Answers 3

  1. Try this take out your battery
  2. Wait for 10 seconds
  3. Re Insert the battery without pressing the power button if it turns on itself (witout pressing the power button( then it would be hardware problem. Just clean it with alcohol or tinner and keep pressing on it to clean the inside of your power swith or if not just replace your power button.
  4. If not auto turn on after inserting the battery then its software problem. Just download the official firmware ang flash your phone via odin.

From Experience : The problem is with your battery. The battery can't produce stable power.

When you go to recovery mode, the power consumption is very low. So, it will stay for some time.

When you turn on the phone, the brand logo is shown, may or may not the Booting is done. Suddenly the phone turns off. Then again turns on and repeat this automatically about 15-20 times.

I have the same issue and after checking for a weak , I found that the battery can't produce the power in a stable manner.

How to check.

  • Take the battery out.
  • check the battery code, power details, etc.
  • Find a similar battery.
  • Put the battery in the phone and try turning it on.

80% it will work.

Try it and if you are in the 20% part, let me know.

  • Tried a battery that previously provided me with a wi-fi hotspot. Nope, didn't work.
    – MickG
    Mar 10, 2017 at 10:13
  • did you checked the voltage and watts of the battery. whether it is same?
    – i--
    Mar 10, 2017 at 10:16
  • Yep, both "3.8V Li-ion BATTERY 3.8V Li-ion BATTERIE 7.98Wh".
    – MickG
    Mar 10, 2017 at 13:53
  • Seems it was something about the battery after all. See update.
    – MickG
    Mar 13, 2017 at 21:32
  • If the answer seems helped you, consider marking it for future visitors.
    – i--
    Mar 14, 2017 at 0:59

The bootloop happens when the boot partition is corrupted or in extreme cases the whole eMMC chip is damaged, the phone boots but can't load the system and all ressources.

Among the causes a defective charger - as you've pointed the phone was left to charge all night long.

Try flashing the phone, this may solve the bootloop.

  • Download the firmware for your model, region and same android version or higher.

  • Download Odin (Windows) or Heimdall (Mac) and Install it.

  • Download Samsung drivers, install them

  • Now open Odin, click on AP slot (PDA for lower version)

  • Browse to where you have unzipped the firmware

  • Select the file (must end with .md5 or .tar)

  • Now put the phone to Download mode (Volume down + Home + Power), then press Volume Up

  • Connect the phone to the computer the click on START. Wait till the end.

  • You phone should reboot and boot normally

Using Heimdall: follow this guide.

Let us know if you experience any errors. We'll try to help.

PS: All your personal data will be wiped.

  • You mean download android firmware on my computer? Also, it's a mac, so "Odin (Windows)" cannot be installed on it… Mac version?
    – MickG
    Mar 10, 2017 at 16:29
  • Yes exactly search for your model number firmware (GT-I9300 for international variant). Download Heimdall as you're on Mac
    – esQmo_
    Mar 10, 2017 at 16:32
  • For Heimdall, I've added a link. check it
    – esQmo_
    Mar 10, 2017 at 16:48
  • Tried googling "download android 4.4.4 GT-i9301I on Mac", got this, not sure what to open. Anyway, is there any way of saving my data before wiping it? I'd only need to save contacts, SMS's and Whatsapp messages.
    – MickG
    Mar 10, 2017 at 17:01
  • Not sure you can save anything. Go to sammobile.com, you'll find your form
    – esQmo_
    Mar 10, 2017 at 17:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .