2

No matter what I do, I can't get my phone to vibrate for text messages anymore.

I am running Cyanogenmod 7.1.0.

It vibrates for phone calls and for haptic feedback, so there's obviously nothing wrong with the hardware or notifications in general.

  • Settings → Sound → Vibrate: Always
  • Stock messaging app → Settings → Notification settings → Vibrate: Also vibrate when notified, Always, and Vibrate Pattern: Multiple short (which used to work)

I don't get it.

1
+50

I had a rom that failed to vibrate certain "very short duration vibrations" (or those of low strength vibrations). I am not sure if its just a hardware limitation of my phone or the rom in particular, but you could try an app like Handcent for now and play around the vibration settings in there. Handcent SMS allows you to fine tune the vibrations, adjust the intervals between each vibrations in milliseconds etc..

  • Uhhh.... I had it on "multiple short". I changed it to "normal", and it vibrated! I changed it back to "multiple short", and it still vibrates. Soooo, I guess I just had to change the vibrate pattern and then change it back? Whatever, you fixed it. – endolith Jan 6 '12 at 15:14
  • @endolith Thats weird I had a similar problem too.. I think the "multiple short" vibration patterns are quite unstable and in some cases it vibrates while otherwise it won't. Probably due to a bad quality vibration module inside the phone I guess. – Irfan Jan 7 '12 at 10:37
  • I don't think it has anything to do with the hardware. My phone uses haptic feedback for the button presses, which is just a very short vibration. It has never had any problems with that. I think there's just a bug in the vibration software for that app or CM. – endolith Jan 7 '12 at 18:53
0

There's a workaround here that might work for you: Vibrate still not working for SMS/MMS notification

  • Doesn't work for me. :/ – endolith Jan 2 '12 at 19:39
-3

Do check the battery settings or profile settings as you might have selected the profile while is restricting the vibration notifications.

If still dosen't work it maybe due to some hardware fault ( assuming you have already checked the above settings ) but i would recommend flashing the ROM to customer CM7 roms and then check if you still have the same issue.

P.S.

You could try using the Hardware Reset Method also.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.