2

I have created hotspot from my Andriod mobile and using Internet on laptop Windows 7 but I'm unable to connect to websites which don't start with www..

The error:

If your computer or network is protected by a firewall or proxy, make sure that Firefox is permitted to access the Web

Should the settings be done on mobile or laptop? What should I change?

Note I am using mobile data. Websites starting with www. are working fine. The problem doesn't occur on my phone. Also everything is OK when my laptop uses LAN.

Mobile(alone with data) and laptop(alone with LAN) works fine , it is only when mobile hotspot is used in laptop, i am not able to access websites which don't start with www.

  • 2
    Check the Firefox setting in the about:config for browser.fixup.alternate.prefix. It's default is 'www.' (uncluding the period), unless changed. – wbogacz Mar 10 '17 at 16:41
  • 1
    @wbogacz can please suggest any link how to do it? – Amruth A Mar 10 '17 at 16:47
2
+50

How do I prevent Firefox to use: www.foo.bar instead of foo.bar? suggests setting browser.fixup.alternate.enabled to disabled to be a working solution

Steps Involved Source

  • Turning off Domain Guessing

    • In the address bar, type about:config and press Enter

    • The about:config "This might void your warranty!" warning page may appear. Click I'll be careful, I promise! to continue to the about:config page. (There's no warranty with Mozilla so I suppose this is to just a warning joke)

    • In the Search field, type fixup.Double-click the browser.fixup.alternate.enabled preference to set its value to false.

  • Changing the prefix (to www )

    • In the about:config page, double-click the browser.fixup.alternate.prefix

    • In the pop up menu enter www. ( if that doesn't help try www without . )

This is perhaps what was suggested in comment

  • ok will try , but one thing websites without www. is working with other LAN network on my laptop , it does not work only when connected to mobile data hotspot , so i was thinking settings should be done on mobile ,also please note that websites works on my mobile. – Amruth A Mar 13 '17 at 6:50
  • 1
    IDK why that happens but this be a workaround. AFAIK there is nothing to tweak in hotspot settings – beeshyams Mar 13 '17 at 7:05
  • Thanks for the bounty . Did it work for you? – beeshyams Mar 20 '17 at 10:55
  • 1
    will check today , was using proxy websites.. – Amruth A Mar 20 '17 at 11:35
  • Good that it is solved :) – beeshyams Mar 22 '17 at 16:05
0

1)Go Wireless Network connections Status.

2)Properties

3)Networking

4)Configure

After doing this there was error DHCP not there , I gave auto fix in windows. And all websites started working.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.