4

I recently got a new phone, a Landvo XM100 Plus.

It sometimes reboots randomly which doesn't bother me much, but what's annoying is that it keeps setting the system language to german. I did not have these issues on my old phone (Samsung Galaxy S3), and I don't have the problem when there is no SIM Card inserted. However, I'm using the same SIM that I used in my old phone, so I'm really confused as to what is going on.

I tried googling the issue and I ended up at a few different boards with everyone basically scratching their heads.

Any ideas?

Could it be the custom ROM the manufacturer uses? I don't quite want to flash my phone with a different OS right now since I still got warranty.

Best regards!

  • Some phones use the SIM language when the setting is set to automatic. Try changing the language from automatic to your preferred one. – esQmo_ Mar 14 '17 at 14:12
  • 1
    I can absolutely not find such an option on my phone, I've been through all the points in my settings (even developer options) - though to be fair I don't really know what I'm looking for exactly. If you mean the "Language and Input" setting, I changed that. Every time. It just resets after reboot. – Wep0n Mar 15 '17 at 7:58
  • I was referring​to the one in the Language and Input.. So okay, the problem is more complicated than I thought. Only the language settings reset after reboot? – esQmo_ Mar 15 '17 at 9:25
  • 1
    Yup, as far as I can tell anyway. The language is back to german along with the keyboard. The keyboard changes automatically (to QWERTY) when I switch back to english. As I said, this does not occur if no SIM is inserted. Everything else user-related is saved however, like screen brightness, alarms, volume settings etc. It seems like only the language changes. – Wep0n Mar 15 '17 at 9:32
  • +1 to this question to get more attention, may be an expert will give more relevant infos on this issue. – esQmo_ Mar 15 '17 at 9:40
1

I disabled secure start up. I guess secure start up uses the default keyboard (instead of SwiftKey that I normally uses) and that the language of the default keyboard depends on the sim card.

IMG:

(Click to enlarge)

I am using a cubot power (cheap Chinese crap) with a Thai and a Danish sim card. Before the fix, the language changed to Danish every time I rebooted

  • Edited picture to make the text beneath it obvious – beeshyams Nov 5 '18 at 13:48
0

For my device it stopped reverting the language settings after I ticked 'Keypad' in Settings -> Wake-Up Sources, not sure if you have that option depends on android OS version probably.

  • I have since acquired a new phone (for unrelated reasons) from a different manufacturer. I no longer have this problem. I would like to try and verify your solution but I've had to cut my SIM Card down to fit the new phone, it no longer fits into the old one. If I get around to it, I'll try and see if I can check it a different way. – Wep0n Jun 6 '17 at 6:55
-1

I just went and got a new sim and it fixed the problem

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.