1

So I've got a problem with Google Play services where it's stuck in an arm64-v8a architecture while my phone's is armeabi-v7a. It happened when I tried installing a beta version of Google Play Services 10.5.35 for arm/arm64 (XYZ=448). I quickly received the error about an incorrect architecture for my phone (Alcatel Pixi 4, android 6.0. I have a 16GB SD card formatted as internal storage. Google Play Services is built into the phone).

I've tried installing other apks which should work (438/430, beta and non-beta) but they simply gave the error "App not installed" when I did. I've tried uninstalling Google Play Services' updates but couldn't find the option to do so (or at least, it's not where it should be according to some websites). I've performed a factory reset (without restoring a backup). I've tried using Apk Installer.

Still, nothing has worked and the error remains. I need some way to get Google Play Services to the latest version, preferably beta. Also, I'd really like to avoid rooting my phone. I'd be so grateful for any help!

0

Amazing! The whole thing just fixed itself after an update via the Play Store! I'm so glad it actually got fixed! I guess to anyone with a similar issue, this should be good to know. Altough it's a shame I could only wait for this to happen, maybe there's some way to speed up this process.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.