7

I updated my Huawei P9 today and Google's gboard got turned on by default, and it won't allow me to disable it.

Usually I can switch from Japanese to Korean/English and back, now everytime I want to switch, it goes Japanese to Gboard to Korean to Gboard and back.

3

Here is the method to disable GBoard on stock Android phones (Steps for Huawei phones should be pretty similar)

  1. Go into Settings and tap on Apps

  2. Locate GBoard from the list of apps and tap on it

  3. On the next screen tap on the Disable button

0
  1. Disable your virtual keyboards.
  2. If you are on Windows and have knowledge about using adb, then from CMD shell launch:

    adb shell am start com.android.settings/.inputmethod.InputMethodAndSubtypeEnablerActivity
    
  3. Untick "Use system language"

  4. Select the keyboards you want.
2
  • 1
    Hi there. Could you please give more details about this solution ? What do you mean by disable virtual keyboards ? where do you untick "Use system language" ? Does this need a rooted phone, or does it work on stock ? – mhham Aug 24 '17 at 15:22
  • @mhham am start works without root, it just launches a regular activity. Without trying, it looks like this will work all on vendor-owned (unrooted) phones though I haven't tried it myself and some of the other answers here also don't universally work so take that for what it's worth. – Luc Apr 5 at 21:24
0

As far as I can see from the screenshot you dont have any other keyboard enabled except for Gboard. And Android wont allow you to have "no keyboard". Enable the Huawei keyboard and then you will probably be able to disable the Gboard.

1
  • Are you saying "Google Japanese Input" etc aren't keyboards? – stackoverflower Jul 28 '18 at 23:24
0
  1. Open a terminal (either through adb shell or just on your device).
  2. Get super user privileges: su
  3. Disable gboard with the package manager: pm disable com.google.android.inputmethod.latin

This worked on a Huawei P10 Lite. Not exactly a P9 as you have, but maybe it works for you as well.

I haven't tried without super user access, maybe it also works on vendor-owned devices if you skip the su command.

-1

You can download another keyboard app from Google Play Store or elsewhere then go to Setting > Language and Input.

There, you can see your default or Gboard and the keyboard app you just installed. Now you can just click on default keyboard and click on the keyboard you want.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.