5

I am on Samsung Galaxy J2, rooted with TWRP flashing. I want to convert a GPS Spoofer to a system app.

I tried Link2SD and Titanium Backup, but both of them failed. I tried to move it manually, but in all 3 cases, the app is completely removed from the drawer.

Is there any method?

1

5 Answers 5

4

SuperSU version v2.73 installed by you is systemless as confirmed by you using methods mentioned here How to find that I am rooted with Systemless

Systemless root does not permit changes to be made by you to /system by default. See Systemless Root for details. This is most likely the reason that you are unable to convert installed apps to system apps

To enable this, you have two options:

  1. Follow instructions here Enable /system write in TWRP - Systemless root to make /system writable and then try to install. This should solve the problem (I am also on systemless root but made it writable following this). If this doesn't work, next option below

  2. Revert to traditional root - see Switch over from systemless root to system (traditional) root

1
2

Although OP seems to have SuperSU installed, I am writing this answer for the users of Magisk so as to prevent near duplicate questions from spawning.

Magisk module App Systemizer can make any third-party app a system app systemlessly i.e. without making changes into system partition. Download it from Magisk Manager or via the link and flash it through Magisk or your custom recovery. Reboot and launch a shell using a terminal app, such as Terminal Emulator. Follow these commands:

su              
systemize       # loads the tool
1               # this would list all the third-party apps that can be systemized
ENTER_DIGIT     # enter the digit corresponding to the app you want systemized
CHOOSE_LOCATION # choose the digit corresponding to /system/app or /system/priv-app
TYPE y OR n     # y to reboot immediately and n to reboot later

After reboot your app would show up as a system app. When you get comfortable with this tool you can direct everything through a single command. Follow the module's link for usage instructions.

1
  • Magisk Manager can install this module itself
    – user924
    Feb 21, 2019 at 7:22
0

Assuming you have ROOT access, your apk file is present on Windows desktop and you are on Lollipop or lower then,

  • Install adbd Insecure by ChainFire, launch it and tick the first case.

Why should you install adbd Insecure? -> to be able to adb remount on production builds.

Then from CMD Shell type:

adb remount    
adb push c:\users\username\desktop\yourapk.apk /system/app/
adb shell
chmod 644 /system/app/yourapk.apk
adb reboot
0
0

You can use Lucky Patcher to convert apps to system apps.

  1. Open Lucky Patcher.
  2. Select the app you want to move, then click Tools (if there is a dialog box that appears with a warning message, click Yes).
  3. Click "Move to /system/app" (or "Move to /system/priv-app").

Another app that is also able to convert user apps to system apps is System app remover.

Note: Beware that Google Play Protect will warn about Lucky Patcher being harmful and will prevent you from installing it.

0

I had a similar problem with a few other apps. It's most likely not a problem with the root. I have Marshmallow 6.0.1. I used Link2SD.

Solution: after converting to a system app, you need to restart the phone, wait for a few minutes, and restart again. Do this 2-3 times then the app will appear.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .