1

Recently my Huawei P9 somehow got updated to EMUI 5.0, and everything was going well except the updater setting and camera app was gone and the flashlight would not turn on. I decided to backup my data and perform a factory reset. However, the reset failed and when I turned it on the only keyboard installed was Google Voice Typing and I coudn't use it because I'm Asian and it woudn't recognize what I said. I tried skipping all the steps but it seemed to be stuck at "checking info". After countless times of resetting it i found out I could connect to wifi when I reset it from eRecovery. After doing so, I installed a keyboard using the built in SD card. I tried to use ADB but it only managed to connect once and I made a typo and I cound't connect again. I tried rolling it back but I simply coudn't get past the factory reset stage. Any help would be appreciated, thanks in advance.

Edit: I forgot to mention that I unlocked the bootloader and flashed TWRP onto my device(though I'm not sure if the failed reset removed it).

  • Just flash a stock firmware. Problem should be solved – esQmo_ Mar 18 '17 at 15:31
  • @esQmo I can't connect thru adb or is there another way? – Adrian Lew Mar 18 '17 at 23:15
  • Sry my bad, I tried doing so but I can't get past the reset stage – Adrian Lew Mar 18 '17 at 23:43
  • Flash through SD card. Download​ the firmware then put it in the SD card (put only the dload folder). Power on the phone holding both volume up and down – esQmo_ Mar 19 '17 at 0:23
  • Yeah, I did that but turns out i didn't have to use the intermediate package everything works well now thanks – Adrian Lew Mar 19 '17 at 8:33
0

Reflash the stock firmware. If you have a recovery installed then format the data and system partition and then flash the rom that you like. Or you can just make a dload folder in your sdcard ,put the stock firmware for your device and then boot by pressing all the keys of your device (Volume Up + Volume Down + Power). It will make your device do a forced update.

0

Turns out I just had to skip the intermediate package and jump to the stock firmware.

EDIT: On the official page, to downgrade, it states to flash an intermediate firmware. The fix was to simply skip it and flash the old one.

  • Thanks for self answering . Please add sufficient detail so that future visitors can benefit from your solution – beeshyams Aug 23 '17 at 15:44

Not the answer you're looking for? Browse other questions tagged or ask your own question.