-5

I am a graphics student learning how to develop OpenGL ES applications on Android using the SDK/NDK. However, the SDK gives me a few errors, pasted below:

error1

Also, I get this error in the terminal: error2

Thus, I cannot update the packages. Is this because of a Virtualbox issue? Please help.

1

Those console warnings are not relevant here. Your first screenshot tells you exactly what's wrong — you're trying to install something without first installing what it depends on.

You should not be installing any of the Android system images, since you're using VirtualBox. You cannot run an Android virtual machine inside an Ubuntu virtual machine, so those images are useless to you.

Why don't you install the Android SDK on your host OS?

0

Not the answer you're looking for? Browse other questions tagged or ask your own question.