Internet search reveals a couple of ways of doing this:

  • This reddit post suggests a couple of methods, which are simple

  • In contrast, this XDA mentions that even flashing boot.img is not enough and you need to clean flash system as well - in other words complete ROM

Do I run a risk if I choose the first method and flash the last version of traditional root?

Anything else I need to bear in mind ?

Edit: Any other method ?

  • 1
    Rather than answering to your question's body, I answered to the title. Do make me know if it solves your issue.
    – Grimoire
    Mar 21, 2017 at 19:15
  • @DeathMaskSalesman: That's fine - that's the crux. Will revert if there is a problem ( some xposed issues I am attributing to systemless root, as a guess - if they are resolved otherwise, needn't revert)
    – beeshyams
    Mar 21, 2017 at 19:23

1 Answer 1


I had this very issue some time ago. In my case, this Reddit post helped.

Basically, to migrate to the traditional system root, you need to have the TWRP recovery installed, the latest SuperSU flashable ZIP, your phone to be already systemlessly rooted and SuperSU by Chainfire to be your root manager app.

Next, boot to Android, open SuperSU and navigate to the Settings tab. Find the Full Unroot button and tap it. When SuperSU asks if you're sure to unroot, accept. When it asks whether to restore the old boot.img, deny.

When the phone reboots, input the appropriate keys and boot into TWRP. Once there, make sure that the /data partition be mounted. Then, under the Advanced menu, start TWRP's Terminal and issue the following commands:

cd /data
echo SYSTEMLESS=false > .supersu

. Alternatively, you can use

echo SYSTEMLESS=false > /data/.supersu

to achieve the same result. This creates the file .supersu inside /data.

Finally, flash the SuperSU ZIP to force SuperSU to use the standard, old root procedure.

The .supersu file

This file is checked (e.g. sourced) by the SuperSU ZIP. If it finds the entry SYSTEMLESS and it has value false, the installer will perform a system install. If the value is true, the installation will be systemless.

  • Thanks . Was xposed unaffected? Just for curiosity what does the command exactly do ? Asking since for my device ( Moto X Play ) I had to echo "SYSTEMLESS=true" >> /data/.supersu to make it work ( IDK of that makes a difference to your solution) +1
    – beeshyams
    Mar 21, 2017 at 19:16
  • Also, can I flash the last version of system root or any version as good?
    – beeshyams
    Mar 21, 2017 at 19:18
  • @beeshyams I cannot say if Xposed will work fine - I was on Android 7 when applying this solution, so no Xposed - but if the issue was that Xposed couldn't find su, then yes, it'll work again. My two commands and yours do the same thing: they create the file .supersu inside /data, and write the string SYSTEMLESS=false inside it. This file is checked by SuperSU's ZIP, and if that string is set to false, then the rooting method will be the traditional one. Lastly, my test was performed with the SuperSU ZIP v2.79-201612051815, so I cannot really say it'll work for an older ZIP.
    – Grimoire
    Mar 21, 2017 at 19:37
  • I am on 2.79 version , so it should be fine
    – beeshyams
    Mar 21, 2017 at 19:51
  • It's interesting that you advise not to restore boot image when doing full unroot. I tried your method and because I did not restore it I never got root when installing in system mode not system-less. That's probably also the reason @beeshyams had problems. Also he did put SYSTEMLESS=true (not false) so it seems he was moving from system mode to systemless which is the exact contrary of what this article is about.
    – Marc Elser
    Oct 10, 2017 at 12:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .