1

Is there a way to make Android/a Galaxy S7 prompt Win 7 to install the drivers for MTP?

I own two S7 I use for work, one I've had for a while and used it to develop Android apps, the second I got a week ago and set it up today. Both I updated to Nougat 7.0 today (they were both on 6.0 with different Builds) and my old one instantly made Windows install the drivers for MTP and PTP but the new one only did it for PTP. I can still access everything on it with MTP but Eclipse/Android Studio/adb devices don't see it with that.

I tried killing the adb server, unplugging, restarting, changing the setting to PTP and back,... but nothing has worked so far.

The devloper mode and USB debugging are enabled on both S7s and I also updated the Google USB driver and installed the Android 7.0 SDK Platform through the Android SDK Manager today. The latest version of Kies is installed too but it also can't see the new S7 in MTP mode (to be honest, didn't test with PTP mode).

So, is there a way to kind of reset the whole MTP deal on the new S7 (preferebly without resetting the phone), so it makes Win 7 look for drivers again?

Bonus question: Can I make Nougat's developer settings' USB debugging default to PTP? Every time I unplug the phone, Android sets it back to MTP.

0

Try this:

  • Open the dialer

  • Type *#0808#, should open the USBSettings menu.

  • On the window that comes up, on USB, tick AP. On USB Settings tick MTP + ADB

  • Reboot the phone. Windows should now install drivers and the phone should be detected in debugging mode.

Image

Can I make Nougat's developer settings' USB debugging default to PTP? Every time I unplug the phone, Android sets it back to MTP.

Try:

  • Pull down the notification panel

  • Then touch the USB sticky notification

  • Select Tranferring media file (= MTP)

Your phone should remember this setting and never forget again :D

enter image description here

UPDATE:

Try *#9090# and select DM/DUN over HSIC

Also try revoking the USB debugging authorizations in the Developer options. Works fine in most time.

  • Unfortunately neither worked. Ad 1. It was already set to AP/MTP + ADB and "MTP" (without "ADB"), "PTP" and "PTP+ADB" aren't even in the list like on your screenshot. I changed it to something else, changed it back, saved, the did it again and chose "reboot" this time (all while it was connected to my PC) but it didn't install any drivers and Eclipse,... still don't find the phone. Ad 2. I did that but as soon as I unplug the S7 or restart it, it's back on MTP. – Neph Mar 22 '17 at 15:16
  • Ad1. So there should be something wrong with this device. Bad USB connector may be. Try cleaning it and try again. Ad. 2 "... back to MTP." or PTP? – esQmo_ Mar 22 '17 at 15:53
  • Just saw your update: "DM/DUN over HSIC"? There's "DM TRACE ITEM SEL" but nothing else that's similar. I already tried disabling the developer options and usb debugging with a restart afterwards but no change. Like I said, PTP works fine, so I think/hope it's not the connector. What do you mean by "try cleaning it"? Reset the phone? Ad 2. I set it to "Midi" and it actually installed a new driver through Windows Update, so even that works. It's possible that it tried to install it for MTP too in the beginning but wasn't successful - no idea how to make it search again. – Neph Mar 22 '17 at 19:03
  • I mean cleaning the USB connector. Sorry bad English – esQmo_ Mar 22 '17 at 19:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.