1

If I set my phone to Vibrate or Silent modes, it's still making audible notifications for GMail, Hangouts, Waze, and maybe other things.

It has worked as expected for years, and then started doing this in the last few weeks. I don't see any other setting anywhere that adjusts this.

All 3 of the main volume controls are at zero. Is there somewhere else I should look?

The loudness of the notifications matches the loudness of the notification slider when it's not muted. Like if I set it to high level and then go to silent mode, the notifications are still high level. If I set it to the lowest level and then go to silent mode, the notifications are at the lowest level.

CM11, Android 4.4.4, Samsung Galaxy S Relay

  • If wbogacz solution didn't help and you are OK with an automation option, let me know – beeshyams Mar 23 '17 at 5:38
  • @beeshyams How would you automate it? – endolith Mar 24 '17 at 21:40
  • Posted.. Please check and revert – beeshyams Mar 25 '17 at 2:52
2

It is a fact that there are elements of the audio on devices that escape the Vibrate/Silent mode you are dealing with. I was disturbed at the difficulties of closing all audio channels, too. Years ago I found an app that made all the manipulation of the sounds on my devices clear and simple: Volume Ace. It makes it clear which systems still allow audio when in Vibrate mode, or when directed to be Silent. It allows you to control the outliers right from within a single screen, rather than through multiple menus or other activities. It allows for audio profiles for time of day, etc. It allows your settings to be saved, and recalled in case of unintentional disruption. I haven't needed to play with most aspects of audio in some time.

DISCLAIMER: I am not the developer, just a long-time satisfied user. I hope you find it as useful.

1

Automation is the preferred option. Many apps are available. I prefer using MacroDroid , since it is free (upto 5 macros) and easy to learn.


Your macro would look like this

  • Macro : Mute Notification (name of macro as example)

Trigger: Notification → Notification received → Select Application (S) → Gmail and others → Text content contains → Any

Action: Notification Sound ( select none, since you don't want any)

Constraints: Ringer Volume → Vibrate or Silent ( Macro works in these conditions only )

  • Actually it seems I can adjust this in Tasker, which I already use. I don't understand why the Notification Sound volume is no longer controlled by the system volume though. – endolith Mar 28 '17 at 0:28
  • Sounds have been messed up after kit kat I understand - in the sense of how they are handled – beeshyams Mar 28 '17 at 1:46
  • See for instance this question for changes stackoverflow.com/q/21701432/5585644 – beeshyams Mar 28 '17 at 3:15
  • but I didn't upgrade the OS, it just changed – endolith Mar 28 '17 at 3:24
  • That's strange though – beeshyams Mar 28 '17 at 3:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.