3

So here's the deal. I'm running CM 12.1 on my phone.

I really need/want to flash TWRP, but every single time I do it (via Heimdall), no matter what I do, I always get Cyanogen Recovery, which is completely useless, back over it when I boot into recovery mode. I tried shutting the phone off after flashing and booting directly into recovery mode as some people suggested, but it makes no difference. Yes, I've turned off the option in developer options to update cyanogen recovery, but 12.1 ignores that setting anyways and rewrites any custom recoveries anyways.

Does anyone know how I can get rid of cm recovery and replace it with TWRP? I would be extremely thankful.

EDIT: Just tried flashing via adb, didn't work either. Imma start pulling my hair out at this rate.

  • Found any solution yet? Stuck with the same problem here – sigy Nov 3 '17 at 21:09
  • To clarify, did you try using adb or fastboot to flash? Also, you shouldn't "get" something different than what you downloaded. Try using a different file and using fasboot to flash. – CMWAidan x Jun 27 at 20:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.