2

KingRoot's Superuser, while effective at its main purpose, is throwing up adware lockscreens. I'd like to replace it with SuperSU but have had difficulty finding instructions detailed enough for my low level of knowledge.

I tried just installing SuperSU from the play store but that failed.

When googling, I see results for kingroot, kingoroot, and I don't even know if they are the same or not.

The Superuser package on my device is com.kingouser.com version 2.1.6.8 (2168). The device is an Azpen A746, the world's 2nd cheapest tablet.

Detailed information on replacing this SuperUser with SuperSu would be greatly appreciated.

3

TL;DR - skip to the STEPS section

Kingroot and Kingoroot are two completely different apps, made by two completely different group of developers.

Kingroot, while it is probably the leading app for "1-Click-Root" solutions, also installs a ton of bloatware and annoying services that you may or may not know about.

Kingoroot I can't really speak too much about, considering there have always been many other solutions to achieving root including Kingroot.

Okay so I've used this method dozens of times and it works 99% of the time. The only time I haven't had it work was for a Verizon HTC One M8, since Kingroot only gives (at least at the time) temproot it took a few tries to get it working properly. I give all credit to w0lfdroid to finding it, and the original guide can be found here http://www.w0lfdroid.com/2015/05/How-to-Remove-Replace-KingUser-KingRoot-with-SuperSU.html

WARNING

This may leave your device in an unrooted state, if this happens then just run Kingroot again and it will fix itself.

STEPS

  1. Download the following three items:

https://play.google.com/store/apps/details?id=jackpal.androidterm&hl=en

--(Terminal Emulator App / Alternatively you can just use ADB shell)--

http://tiny.cc/1a5lyx

--(Zip archive containing necessary files / v1)--

http://tiny.cc/fo78zx

--(Zip archive containing necessary files / v2)--

  1. The two zip archives contain the same files, but if the steps don't return the desired result using the v1 files, then repeat the steps using the v2 files.
  2. Extract the "mrw" folder from the zip archive and place it anywhere in "/sdcard". For convenience let's just say you're not using a computer and instead doing this all from the phone you're wishing to switch from Kingroot to SU. Downloading the files will put them inside /sdcard/Download. So navigate to there using the built-in file explorer (or Root Browser if you don't have one), extract "mrw" from the zip, and proceed to install Terminal Emulator.
  3. Open Terminal Emulator and type the following commands:

su

sh /sdcard/Download/mrw/root.sh

  1. This will return a ton of text and quite a few errors, don't worry about it, I've never had it not return some errors. When finished it will install SuperSU automatically and open the app, asking you if you'd like to install the necessary binaries. Tap "Yes" and choose the option that is NOT to install in recovery.
  2. At this point it will go one of two ways: either the binary installation will fail, at which point you'll have to re-root with Kingroot and repeat the steps using the other zip files; or the binary installation will succeed and you'll need to reboot the device. Upon booting you will see Kingroot and all associated files have been removed, and replaced instead with SuperSU.

If neither of these methods work there is a paid app in Play Store called Super-SuMe that's supposed to be specifically made for removing Kingroot and installing SuperSU, although despite purchasing it multiple times I have never once had anything happen besides either a reboot, force close, or the app hangs.

Best of luck.

  • Thanks for the detailed instructions. I will give it a try. I just tried the paid app and it didn't work for me either. – Organic Marble Mar 23 '17 at 20:51
  • Sorry to hear, that app should be pulled from the Play Store because that dude is banking off of nothing. Feel free to ask me whatever if you need some help during the process. – therealjayvi Mar 23 '17 at 20:55
  • Looking through the script, I see lots of references to com.kingroot.kinguser, but none to com.kingouser.com, which is what I have. I don't think this is going to work for me. – Organic Marble Mar 23 '17 at 20:57
  • So wait, your question was asking how to change Kingroot to SU, but you're using Kingo-root? – therealjayvi Mar 23 '17 at 21:00
  • Like I said in the question, I am not smart enough to know the difference. – Organic Marble Mar 23 '17 at 21:03
2

Whether it is "Kingroot" or "Kingo Superuser" you are trying to swap to SuperSU, it will be best to use manual methods as most auto scripts out there doesn't work on all device. The simplest and most easiest way to do this does not even required any apps than a file manager. This can be done using ES File Explorer.

I've once faced an issue with kingoroot. It starts displaying annoying ads and battery saver on my lock screen without any switch to disable it, which is very annoying and RAM consuming. After trying an auto-script app called "SuperSume" which unfortunately doesn't work, I later found out how to remove it and swap it with SuperSU manually. This method works for phones with Kingroot or Kingoroot Kingo superuser.

I wrote a detailed guide on it including screenshots and all the process involved. It is posted here.

The only requirement is ES File Explorer. I use ES because it has root explorer built-in.

Give it a try.

1

I guess I was overthinking this. I just uninstalled Kingoroot's Superuser app through Apps, then downloaded and installed Super SU from the play store. Still have root. "All too easy" as a certain Sith Lord would say.

The last straw was when Kingoroot Superuser installed an unwanted app without asking. It had to die after that.

-1

Just going to add this on topr of therealjavi's answer in case there are other people like me who got pretty stuck. Finally got this right after a couple runs or so.

If, after updating the binary according to the instruction given above, your phone prompts that you have two superuser apps now [instead of having the kinguser automatically removed], find a little time to unsinstall that little pesky app, [in my case, I used Link2SD which is available in the PlayStore,] then go back to the terminal emulator, and rerun the scripts again. Voila, you're done.

I also had the problem of ending up installing SuperSu on my sdcard. To fix that [not sure if necessary or I'm just paranoid], I did the following:

  1. Used native setting of android to move SuperSU to Internal Storage
  2. Used Link2SD to convert SuperSU to system app
  3. Reboot.

Btw, I did this on Cloudfone Excite 501o (Android ver. 4.2.2 [KitKat]). I used iRoot (previously known as vRoot, but not sure how similar it is to VRoot which also exists now) to root the phone, and ended up getting a Chinese market app and lots of ads.

-2

Read this post to know how to replace kingroot with SuperSu

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.