1

I have set 2min timeout.
The screen goes off after 2min.

The charger is not plugged (batt was at 100%, and after I sleep it would normally be at 95%).

Something happens that turns the screen on, and it will remain on forever (until I wakeup and find out it spent 35% of the battery...)

The only new notification was a provider unblockeable promo message, but that never caused that problem.

It has been happening for a few days now.

I need to enforce the screen go off, other than using the system option that is clearly not working.

1

It maybe that text notifications are waking up the screen at night. In that case you may need to completely disable notifications at night.

Some resolutions include:

  1. Turn off message notification completely

You can stop the screen from turning on when you receive a message by disabling the message notification completely but you lose all the notifications, including audio and LED flashing alerts.

Depending on your device, navigate to Menu > Settings > Notifications and turn off.

  1. Turn on Do not disturb feature (Android 6+ )

Do not disturb is a feature that lets you silent all notifications for a specific time period. You can choose to allow messages and calls from select contacts to still alert you when Do not disturb is enabled.

Open the Settings >> Sounds >> Do Not Disturb setting. On the Do not disturb settings screen, tap Block visual disturbances.

You additionally need to turn on the Block when screen is off option.

  1. Using third party apps

Some users claim that apps such as I'm sleeping have the ability to prevent screen wake-ups at night. This app will automatically set your phone to silent mode during the night and optionally disables the LED during the night

credits

  • Did you manage to solve this "screen off" problem? – xavier_fakerat Jun 17 '17 at 7:24
  • mmm... do not disturb... I could use that for 24h!!! and only allow trusted ppl to annoy me xD. Have to try it now thx! – Aquarius Power Feb 19 at 2:05
  • Some options are not available. But doNotDisturb will work 90% of the time! I will try to uninstall the stk package (sim toolkit) w/o root, tip from linked question, thx! – VeganEye Mar 22 at 15:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.