1

I've been trying to root my OPO for two days now and I've continued to have this issue. After installing Android Studio + the SDK, as well as downloading the Google USB Driver, when I connect my phone to my computer it shows up as an MTP device under unknown devices. If I allow it to automatically download drivers, it becomes a portable device instead. But I need it as an ADB device. I've already started USB debugging on the phone, as well as switched between all the different USB options on the phone (charging, MPT, PTP, MIDI, etc.) and still no good :(

When I try to update the driver for the "MTP" device, the Google USB drivers don't show up, and if I try to browse manually, it comes up with the error message saying how "the folder you specified doesn't contain a compatible driver." What do I do?

Thanks!

0

if you are on windows then you need to manually install adb driver for your device. steps are as follow

Right click on computer and goto manage. then goto device manager find your device and right click on it and from menu choose update driver

now choose let me choose

go next

now browse your google usb driver location

click next

after that you'll see adb driver name then clcik next to install drivers.

see this link for description

https://software.intel.com/en-us/xdk/docs/installing-android-debug-bridge-adb-usb-driver-on-windows

  • In my post I said I already tried that :( Windows says the folder doesn't have a compatible driver in it – PuppingCaps Mar 24 '17 at 17:44
  • 1
    but it works for any device. – Prashant Sawant Mar 25 '17 at 7:55
  • still you may to install adb drive from website of oppo according to your phone – Prashant Sawant Mar 25 '17 at 7:56
  • its not oppo, its OPO, Oneplus One – Enigma Mar 25 '17 at 12:25
  • btw, what you say is a valid solution – Enigma Mar 25 '17 at 12:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.