I've been trying to root my OnePlus One for two days now and I've continued to have this issue. After installing Android Studio + the SDK, as well as downloading the Google USB Driver, when I connect my phone to my computer it shows up as an MTP device under unknown devices.

If I allow it to automatically download drivers, it becomes a portable device instead. But I need it as an ADB device. I've already started USB debugging on the phone, as well as switching between all the different USB options on the phone (charging, MTP, PTP, MIDI, etc.), and still no good.

When I try to update the driver for the "MTP" device, the Google USB drivers don't show up, and if I try to browse manually, it comes up with the error message saying how "the folder you specified doesn't contain a compatible driver."

What do I do?

  • Note: Google USB Driver only works for Google devices (Nexus and Pixel series). OnePlus and other manufacturers need to install their respective OEM drivers.
    – Andrew T.
    Feb 3, 2022 at 17:29

1 Answer 1


If you are on Windows, then you need to manually install the ADB driver for your device. The steps are as follow:

  1. Right-click on Computer and go to Manage.
  2. Go to Device Manager
  3. Find your device and right-click on it
  4. From the menu, choose Update driver
  5. Choose "Let me choose"
  6. Go to next
  7. Browse to your Google USB driver location
  8. Click next
  9. After that, you'll see the ADB driver name, then click next to install drivers

See this link for a description: https://software.intel.com/en-us/xdk/docs/installing-android-debug-bridge-adb-usb-driver-on-windows

  • In my post I said I already tried that :( Windows says the folder doesn't have a compatible driver in it Mar 24, 2017 at 17:44
  • 1
    but it works for any device. Mar 25, 2017 at 7:55
  • still you may to install adb drive from website of oppo according to your phone Mar 25, 2017 at 7:56
  • 1
    its not oppo, its OPO, Oneplus One
    – SubZero
    Mar 25, 2017 at 12:25
  • btw, what you say is a valid solution
    – SubZero
    Mar 25, 2017 at 12:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .