2

I tried to delete ES File Explorer from my Lollipop 5.1.1. I have a system root and the explorer was a system app. In Link2SD app, it said frozen, so I thought it might be useless to keep it.Anyways I preferred the default system app and root explorer.

I tried to delete it and then all the system apps stopped working, and on rebooting my phone (SMJ 200G), I saw very few system apps, I could not install apks, and message app was also crashing. Also SuperSU was gone from launcher.All other installed apps were there. I factory resetted my phone with TWRP's default wipe; starting the phone now, I can not even log in. It asks me to select language, and then it says that Settings has stopped working.

What is the problem? What do I do? Whatever the solution is, please provide a guide too.

  • Always make TWRP backups before doing any manipulations. – Suncatcher Mar 24 '17 at 10:18
1

The problem with root is that you remove all safety belts from you phone. At the moment it is hard to tell what exactly happened but my guess it that you deleted something else than you think you deleted.

Rooting your phone is for very advanced users (I'm personally long term Android user and I never rooted my phone because I think it is not safe).

My suggestion is: re-flash your phone with original firmware and stop using root. In 99.9% of use cases you don't need it.

  • Well, root permissions are in fact handy, you know. Especially when you want to backup some app, instead of taking a whole Nandroid backup. – Death Mask Salesman Mar 24 '17 at 16:36
0

Flash your ROM, that will solve your problem.

To determine the best ROM for you device check this link

Follow these steps for flashing:

1) Reboot your phone into Recovery mode.

2) Head to the "Install" or "Install ZIP from SD Card" section of your recovery.

3) Navigate to the ZIP file you downloaded

4) If you're flashing a ROM different than the one you're currently running, you should wipe data and cache. So, better take a backup prior to this.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.