3

Yesterday my WileyFox Spark+ came in, which is still equipped with COS13.0.1, based on Android 6.0.1. When I tried rooting the phone though, I got stuck at the point of using the TWRP recovery for flashing SuperSU. I until then, I had succesfully followed the following process:

-Enabled 'OEM Bootloader allowed to be unlocked' in Developer Options
-Installed USB drivers and such on PC
-Enabled USB debugging, apps from unknown sources, ADB install unsigned apps allowed etc.
-Enabled fastboot by holding correct buttons and enabling it after
-Flashed TWRP Recovery to phone like this in CMD:

fastboot devices (my phone showed up)  
fastboot flash recovery twrp3100.img  

-Booted into TWRP recovery

A few folders were present there, but almost all were empty. TWRP even said no OS was installed when I wanted to reboot. I was confused for a while, only to discover the OS was still there after booting into System. In tried to flash SuperSU from ADB, but that also didn't work. I issued the following commands in CMD:

adb reboot recovery
(ticked adb sideload in TWRP +wipe dalvik & cache)
adb sideload supersu279.zip

TWRP said it executed succesfully, but failed to access /data and /cache. Turned out the phone was encrypted already from the box. I never considered this an option. It's weird though, because I believe I have heard that flashing SuperSU from ADB should work even with an encrypted phone.

Now the interwebs and Wileyfox themselves say encryption is disabled when you factory reset the phone: https://twitter.com/wileyfox/status/685884111551115264 And so I did, but it just booted into TWRP with the same circumstances. Few folders, almost all empty. SD-card not visible. I tried sideloading SuperSU again, but without result.

Any idea how i should progress further? Did I miss something? 'Cause I have run out of ideas.. :(
I also can find very little about Wileyfoxe phones, so that doesn't help either.
Is it possible to flash SuperSU via fastboot or ODIN or anything?

Anyway, thanks for the help. Cheers.

NB: I don't care about my data being encrypted or not, so decrypting the phone is not an issue for me, if possible/helpful. I'd rather have it gone.

  • In Marshmallow and newer devices, SuperSU must be installed as "systemless". In many devices SuperSU's install script detects this and acts accordingly, in other devices you need to manually do it by adding/creating the file /data/.supersu with the line SYSTEMLESS=true in it. Of course, this could all be avoided by just using Magisk instead of SuperSU. I am not familiar with this device specifically, but in most newer devices adb sideloading does not work to install SuperSU/Magisk, it must be done with TWRP or other recovery. – acejavelin Mar 26 '17 at 14:29
  • @acejavelin I have looked into Magisk and Systemless install of SuperSU, but as far as I can see, both involve flashing .zips, which is not possible on an encrypted device. Any other method to consider? – Bart Mar 26 '17 at 14:51
  • @beeshyams I have searched for a post on his profile, but the only remotely related post is about a LG Optimus running CM11: link I can't find the solution to my question there. Is it this question you were referring to? – Bart Mar 26 '17 at 15:27
  • This one android.stackexchange.com/q/141405/131553 – beeshyams Mar 26 '17 at 15:33
  • This is the self answered one android.stackexchange.com/q/144966/131553 – beeshyams Mar 26 '17 at 15:37
1

TWRP allows you to format data, this will clear the encryption and ALL your data of course, then you can mount the clean partition with mtp pass zips and flash the usual way.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.