1

The update to marshmallow (finally) came through on my Samsung S5 mini yesterday. The update seemed to go smoothly, but now starting the camera app or the torch app immediately gives a "Warning: camera failed", and exits the app.

So far I've tried everything on this list, which is the most comprehensive I could find (short of a factory reset - I'd like to avoid that if possible)

  • restart camera

  • restart device

  • clear camera cache and data

  • clear gallery cache and data

  • smart stay was already off

  • safe mode (same error message)

  • wipe cache partition

What else could I try?

It may (or may not) be relevant that I took advantage of the major new feature of marshmallow to restrict permissions for many apps, and to disable some of the bloatware. Of course, the camera app still has permission to access the camera. As part of my troubleshooting I have restored full permissions to the camera and gallery apps.

If nothing can be done, is it correct to assume that it's impossible to roll back the update? And that Samsung/Android developers won't release a fix unless there are a large number of people with the problem?

1

As Murphy would have it, I spend 10 minutes putting together a question and then the next thing I try solves it...

In the end it was fixed by switching off and removing the battery for a while (~30s). This is mentioned in one of the comments in the linked article.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.