1

I just picked up a new Honor 8 (running EMUI 5/Android Nougat) and I'm having an odd problem when receiving SMS messages.

Whenever I get a message, an odd string of text with a length of 16, starting with a tilde~, like ~l/Adk/ljAdADFWjlk, is appended to it. This is regardless of my SMS app (I've tried the preinstalled one, Pulse, and Google's Android Messages).

Here's an image of a conversation:

screenshot
Screenshot (click to enlarge)

How can I stop that random string of text from appearing after the intended message?


Edit: For extra details, my carrier is Project Fi (reduced to just T-Mobile on the new GSM-only phone) and the issue occurs regardless of sender, be it an iPhone or Android phone.

2

It looks like there's something wrong in your carrier's SMS router. You should contact your carrier and ask for support.
There's no encoding issues in this case, so I disagree with @beeshyams . The appended text is a stream of base64-encoded data, which after being decoded, resembles a stream of 11-byte data. According to my experience, it is very likely some metadata of the SMS message you received. You can safely ignore it.

Edit: Merged information from comments.
This is a general phenomenon of using Project Fi's service on a non-Fi phone. Discussions are here and here. A solution is to use Google Hangouts for text messaging.

Appendix: Decoded info from image (re-formatted manually)

$ base64 -d | hexdump -Cv
q/Pj/QAHwY+Jhgg= : AB F3 E3 FD 00 07 C1 8F 89 86 08
jaT2JQAcd3EM7Ag= : 8D A4 F6 25 00 1C 77 71 0C EC 08
BMXciQANmWXBLQg= : 04 C5 DC 89 00 0D 99 65 C1 2D 08 
1

In addition to the answer above, it looks like anything interfering with the Google Fi app can also cause the problem.

This started happening on my kids' phones (Nexus 6P and Google Pixel) because I had blocked access to the Google Fi app using the Family Link app since I didn't see any reason why they needed to have access to it.

To fix it, open the Family Link app on your parent device, open your child's management tile, tap "Manage Settings", then "Android Apps", then select the "Blocked" tab. If Google Fi is in the list, select it and allow access.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.