1

I just picked up a new Honor 8 (running EMUI 5/Android Nougat) and I'm having an odd problem when receiving SMS messages.

Whenever I get a message, an odd string of text with a length of 16, starting with a tilde~, like ~l/Adk/ljAdADFWjlk, is appended to it. This is regardless of my SMS app (I've tried the preinstalled one, Pulse, and Google's Android Messages).

Here's an image of a conversation:

screenshot
Screenshot (click to enlarge)

How can I stop that random string of text from appearing after the intended message?


Edit: For extra details, my carrier is Project Fi (reduced to just T-Mobile on the new GSM-only phone) and the issue occurs regardless of sender, be it an iPhone or Android phone.

2
2

It looks like there's something wrong in your carrier's SMS router. You should contact your carrier and ask for support.
There's no encoding issues in this case, so I disagree with @beeshyams . The appended text is a stream of base64-encoded data, which after being decoded, resembles a stream of 11-byte data. According to my experience, it is very likely some metadata of the SMS message you received. You can safely ignore it.

Edit: Merged information from comments.
This is a general phenomenon of using Project Fi's service on a non-Fi phone. Discussions are here and here. A solution is to use Google Hangouts for text messaging.

Appendix: Decoded info from image (re-formatted manually)

$ base64 -d | hexdump -Cv
q/Pj/QAHwY+Jhgg= : AB F3 E3 FD 00 07 C1 8F 89 86 08
jaT2JQAcd3EM7Ag= : 8D A4 F6 25 00 1C 77 71 0C EC 08
BMXciQANmWXBLQg= : 04 C5 DC 89 00 0D 99 65 C1 2D 08 
2
2

In addition to the answer above, it looks like anything interfering with the Google Fi app can also cause the problem.

This started happening on my kids' phones (Nexus 6P and Google Pixel) because I had blocked access to the Google Fi app using the Family Link app since I didn't see any reason why they needed to have access to it.

To fix it, open the Family Link app on your parent device, open your child's management tile, tap "Manage Settings", then "Android Apps", then select the "Blocked" tab. If Google Fi is in the list, select it and allow access.

2
  • Added data point: My wife and I are also Fi users, and this just started happening today on texts coming from her. The only possible change I can think of is the addition of Fitbit application and integration (a Christmas present!). That may also constitute "interfering" with google Fi. BTW, both phones are Pixels. Happy New Year! – Tupelo Thistlehead Jan 1 '20 at 18:10
  • This is the correct answer in 2021. Android can also remove the "Google Fi" app permissions if the app isn't used in a while and you can fix that by going to Settings - APPS - Google Fi - Permissions and re-enable them. – Brad Bamford Feb 18 at 17:46
1

Simply launching the Fi app, then rebooting the phone worked for me. (I had not blocked the app, so I think Fi was just having a problem).

0

Solution for me (so far) on my Galaxy S20 was to disable 'Optimize Battery Usage' for the Google Fi app. (Setting,Apps, three vertial dots in the top right corner, Special Access, Optimize battery usage, Select All, Find Google Fi App and move the slider to the left).

Had to do this as well for my Tesla App to open my car doors and Arlo App to get notifications from my home cameras.

1
  • I know how you feel. I had to do the same thing for my app that polishes my gold bullion and my app that that turns on my Bugatti. – RockPaperLz- Mask it or Casket Mar 11 at 21:23
-1

I started having this problem after switching from AT&T to Google Fi about a year ago. I found a few posts where people said to download the Google Messages app, tap the three dots to get into settings, select Chat Features and turn this off. I updated my apps from Play store, than I went back to the Google Messages app and at the bottom of the screen it was now asking if I wanted to enable advanced message features. I tapped yes, had to give it permission, had to agree to not limit the app's battery usage, and now I can access the Chat Features in Google Messages. Although this worked for me, it didn't for my fiance.

My other solution is to install "Google Carrier Services" app. Installing it made Google Fi to show up with an update, so I updated it.

These steps solved the problem for both me and my fiance.

1
  • 1
    To Readers: the two downvotes (as of 24.02.2021) are not reflective of the usefulness of the answer, but rather of the big wall of text this answer originally was. You would want to try this answer before deeming it unhelpful if you are having the same problem as OP had. – Firelord Feb 24 at 2:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.