2

I've got AirDroid and SSHDroid installed on a ZTE Axon 7 running 7.1.1. The phone has a micro SD card in it, and it can access (read from) that card successfully. What I can't do is copy files onto it. I can log in via ssh and see the file system, but I can't touch it.

I've had a Moto X Pure for the past year, and via SSHDroid and AirDroid I can readily copy files to the SD card.

Is this just a "security" (ie, "pay somebody") thing in the more-proprietary OS on the ZTE phone?

Obviously I can mount the micro SD card directly on the computer, but juggling those tiny cards is kind-of a pain. If there are other solutions, I'd be grateful.

edit — I've tried MTP with the Axon. I plug in the phone and tell it I want to connect as a "media device" with MTP. I then run mtpfs (I'm running Linux on the laptop; Ubuntu 16.04) and I get:

Listing raw device(s)
Device 0 (VID=19d2 and PID=0306) is a ZTE V790/Blade 3.
   Found 1 device(s):
   ZTE: V790/Blade 3 (19d2:0306) @ bus 2, dev 98
Attempting to connect device
Android device detected, assigning default bug flags

Then it just sits there. (I've never had much luck with MTP.)

edit again — ADB seems to work. I don't move files that much (mostly music and audiobooks) and while ADB is a pain it's easier than fiddling with the cards.

  • 1
    Do you insist on wireless, or would using an USB cable be fine? In the latter case, there are several options – like using MTP or ADB. – Izzy Apr 3 '17 at 6:44
  • @Izzy I can't get MTP to work on this phone; I'll extend the answer. – Pointy Apr 3 '17 at 12:41
  • @Izzy ADB works. Thanks for the suggestion! If you want to type in a brief note to that effect I'll upvote and accept. – Pointy Apr 3 '17 at 13:03
  • Alternatively if you also plan to do it via wifi please see File transfer with linux pc through mobile hotspot – xavier_fakerat May 5 '17 at 13:31
2

If you're not insisting on a wireless transfer, using an USB cable would give you at least two options:

  1. Using
  2. Using

With MTP, on connecting the device to your computer you should usually get the option to open it in some file explorer (does so on Windows and on Linux at least). For ADB, you could use adb push to push files to your SD card – or, for your convenience, use an ADB GUI (some are listed here at my site.

For the latter, once connected via USB cable you could make it switch to TCP mode if you need it wireless. Without root, this must be repeated after each boot – with root, there are ways to initiate it without a cable.

Details can be found e.g. via the corresponding tag-wikis: adb and mtp.

Disclosure: The first two links lead to my Android website.

  • Do you have any links on your site as to how to get ADB to start working? I've been trying to reproduce my success from the other day but I cannot. I start the server on the Linux host but adb devices -l never shows anything. – Pointy Apr 6 '17 at 3:30
  • Sure @Pointy – second to last line of my answer. The corresponding tag-wiki has some, and more can be found in the posts using that tag :) If adb devices doesn't show anything, start with those links to configure ADB for your device, e.g. How do I get my device detected by ADB on Linux? – Izzy Apr 6 '17 at 7:26
  • 1
    thanks :) It turned out that my problem involved using the USB-A to USB-C cable directly from my computer. When I used an old USB "extension" cable like I was doing the other day, it immediately started working. I have absolutely no idea why that was the case, but it was about midnight by the time I tried that so I was asking few deep questions. I will probably start looking at rooting the phone because not being able to scp files to the external SD card is just silly. Thanks again! – Pointy Apr 6 '17 at 13:14
1

For those of you dealing with this problem on the Mac, install Android File Transfer.

This was by far the fastest and easiest way to get 30GB of data from my external SD card to my laptop. It can write to the card was well. This software is Mac only!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.