I am trying to install TeX Live using Termux. It's in the Package Manager, but unfortunately the package has some faulty instructions.

Specifically, the package calls wget with a faulty option. If you view https://github.com/termux/termux-packages/tree/master/packages/texlive then the package maintainers have notice this.

So, my question is, does it take a few days to get the new package?
It appears the wget change was made 12 days ago, but I tried to install it today with the same old error.

Second, I can simply issue the wget command manually to get the package, but I don't know where I can put it and force apt to use that package.

  • 1
    What error do you see? By the way, Termux defaults to the wget provided by its own Busybox, meaning that you'll have to manually delete the symlink after installing a full fledged wget via apt install wget.
    – Grimoire
    Apr 4 '17 at 23:03
  • the error is something like "wget --N: unknown option". I am using whatever wget came with termux.
    – Hammar
    Apr 4 '17 at 23:29
  • Which is the Busybox aliased one. What's the output of type wget?
    – Grimoire
    Apr 4 '17 at 23:30
  • 1
    I reinstalled wget with the packages command and then texlive installed without any problems. I don't know if the reason why is because the package maintainer updated the package, or my reinstalling wget worked. But it is now installed!
    – Hammar
    Apr 6 '17 at 11:03
  • have you upgraded your repo index? I.e pkg update && pkg upgrade. If it won't work after syncing repository contents, it may need.some more days. Can you add the error log so we can find a workaround? If you just need it urgently, install Alpine Linux inside a Proot and proot to Alpine environment. Oct 22 '18 at 8:47

The maintainer of Termux, Fredrik Fornwall, owns a discrete site (termux.net) for the APT repository. Before you can apt-get a package, it must be compiled from source and packed up as a Debian package (.deb). So it will take a few days for a commitment to a package.

If you have a Debian package stored on your device (use only Debian packages compiled for Termux), you can let APT install it by apt install /path/to/package.deb or dpkg -i /path/to/package. When apt detects a slash in package specification, it will think it's a path rather than a package name, so apt will install from the file instead of downloading one. In this case apt will also check for dependencies. However if you installed the package with dpkg, then you probably would like to run apt -f install to make sure dependencies are met.

  • Reading the package source, the problem is that the package tries to wget the texlive source (let's call that TLS), unpacks it, and does the necessary compiling. I don't have trouble apt-getting the package, the problem is the package itself tries to get another archive and has a faulty command for doing so. So, my second question above is if I wget TLS manually and put it in a local directory, can I tell apt get not to wget TLS, but use the local one? Can I trick it by putting it in some directory?
    – Hammar
    Apr 3 '17 at 15:12
  • @Hammar Maybe you can try downloading the first package, modify it and then install it. Then apt will follow your modification to avoid wget-ing the second one.
    – iBug
    Apr 3 '17 at 16:58
  • I could try, but I find the guide on termux homepage rather minimal. Is there a better guide on how to do this?
    – Hammar
    Apr 4 '17 at 10:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.