1

I have installed Marshmallow on my Moto G2 using adb. It was a successful installation and everything was working good. Then I realized that none of my SIM was working.
My SIM card shows operator name but it can't get network.

Whenever I try to make a call, It shows me error

Turn off aeroplane mode to make a call

I have checked and found that Aeroplane mode is already off on my device, I tried

  1. Turn on/off aeroplane mode
  2. Reboot my device (Multiple times)
  3. Do factory reset
  4. Wipe Cache and Dalvik cache
  5. Do hard reset
  6. Restore old Kitkat version from backup
  7. Re-installation of ROM (Multiple times)
  8. Insert another SIM to my device (Did not work)
  9. Insert my current SIM to other device (Worked)

But nothing seems to be working for my case. I have read each and everything related to this on internet but was not able to find any solution.

EDIT

I have also tried below command

adb shell settings put global airplane_mode_on 0

to disable aeroplane mode from adb, and checked with below

adb shell settings get global airplane_mode_on

It returns 0 that means Aeroplane mode is off but issue is still there. I still see the error message and can't use my SIM.

EDIT 2

I run below commands with OKAY response.

fastboot flash modem NON-HLOS.bin
fastboot erase modemst1
fastboot erase modemst2
fastboot flash fsg fsg.mbn

Used *#*#4636#*#* and changed network type to WCDMA preferred

Checked IMEI using *#06# and its valid.

EDIT 3

I found that there is no "Cellular Network" option available on my device. Could this be the issue for not reaching out network?

Below is output for getvar all

(bootloader) version: 0.5
(bootloader) version-bootloader: 4887
(bootloader) product: titan
(bootloader) secure: yes
(bootloader) hwrev: 0x8400
(bootloader) radio: 0x5
(bootloader) emmc: 16GB ID=15 REV=07 PRV=0B TYPE=57
(bootloader) ram: 1024MB Hynix S4 SDRAM DIE=4Gb
(bootloader) cpu: MSM8226 CS
(bootloader) serialno: ZX1DXXXXXX
(bootloader) cid: 0x0007
(bootloader) channelid: 0xc0
(bootloader) uid: 2B8DXXXXXX000000000000000000
(bootloader) unlocked: yes
(bootloader) securestate: unlocked
(bootloader) iswarrantyvoid: yes
(bootloader) mot_sst: 3
(bootloader) max-download-size: 536870912
(bootloader) reason: Reboot mode set to fastboot
(bootloader) imei: 3533210XXXXXXXX
(bootloader) meid:
(bootloader) date: 09-11-2014
(bootloader) sku: XT1068
(bootloader) battid: (null)
(bootloader) iccid:
(bootloader) cust_md5:
(bootloader) max-sparse-size: 268435456
(bootloader) current-time: "Tue Apr  4 23:50:50 UTC 2017"
(bootloader) ro.build.fingerprint[0]: motorola/titan_retla_ds/titan_umts
(bootloader) ro.build.fingerprint[1]: ds:6.0/MPB24.65-34-3/3:user/releas
(bootloader) ro.build.fingerprint[2]: e-keys
(bootloader) ro.build.version.full[0]: Blur_Version.24.81.3.titan_retla_
(bootloader) ro.build.version.full[1]: ds.retla.en.01
(bootloader) ro.build.version.qcom[0]: AU_LINUX_ANDROID_LNX.LA.3.5.1_RB1
(bootloader) ro.build.version.qcom[1]: .04.04.02.048.045
(bootloader) version-baseband: MSM8626BP_1032.3116.99.00B DFLT_FSG
(bootloader) kernel.version[0]: Linux version 3.4.42-g0a0ded4 (hudsoncm@
(bootloader) kernel.version[1]: ilclbld86) (gcc version 4.8 (GCC) ) #1 S
(bootloader) kernel.version[2]: MP PREEMPT Mon Aug 22 14:30:22 CDT 2016
(bootloader) sdi.git: git=MBM-NG-V48.87-0-gdc5aeaf
(bootloader) sbl1.git: git=MBM-NG-V48.87-0-gbffe41a
(bootloader) rpm.git: git=MBM-NG-V48.87-0-gbe53f43
(bootloader) tz.git: git=MBM-NG-V48.87-0-g31cba28
(bootloader) aboot.git: git=MBM-NG-V48.87-0-g1b80345
(bootloader) partition-type: raw
(bootloader) partition-size:
(bootloader) qe: qe 1/1
(bootloader) productid: ZX1D62FVGF
(bootloader) sutinfo:
(bootloader) ro.carrier: retin
all: listed above
finished. total time: 0.340s

I am using XT1068_TITAN_RETLA_DS_6.0_MPB24.65-34-3_cid12_CFC.xml.zip dated 2017-02-05 19:29 from this source

I used EasyInstaller.bat to install on my mobile.

Is there any other thing I can try?

11
  • 1
    I have checked everything related to this on @xda forums. All above steps I have found from there only but none seems to be working. Commented Apr 3, 2017 at 17:43
  • 3
    This is almost always a mismatch of radio firmware and kernel. Try reflashing the radio stack. I am assuming your IMEI is valid and not 0?
    – acejavelin
    Commented Apr 3, 2017 at 17:54
  • @acejavelin, thanks for the reply but I am not sure what is a radio firmware. can please guide me with anything. Also my IMEI is valid and not 0. Commented Apr 3, 2017 at 18:03
  • The modem "stack" is the modem Firmware, reflash from your firmware image with fastboot... 'fastboot flash modem NON-HLOS.bin', 'fastboot erase modemst1', 'fastboot erase modemst2', and 'fastboot flash fsg fsg.mbn' and verify OK for each step. You must use the same firmware image your boot.img is from
    – acejavelin
    Commented Apr 3, 2017 at 22:19
  • 1
    Hmm... This is the Indian version right (ro.carrier=retin)? Shouldn't you be using XT1068_TITAN_RETAILDSDS_6.0_MPB24.65-34-3_cid7_CFC.xml.zip? That is for the Indian variant or at least I believe so... Also, I would recommend flashing the firmware manually so you can see if any part fails. Otherwise I got nothing, sorry.
    – acejavelin
    Commented Apr 5, 2017 at 2:23

1 Answer 1

2

It appears you are using the incorrect firmware for your device... Your device is Retail India (RETIN), but the firmware image you are using is Retail Latin America (RETLA). The correct firmware for Retail India is RETAILDSDS (don't ask me why, I have no idea what it stands for other than Dual SIM something). A mismatch of radio firmware to the hardware in your device can cause the operating system to think you are in airplane (aeroplane) mode.

Assuming you have the proper drivers and fastboot installed, use this file and extract it to your fastboot directory, or any known directory if fastboot is in your path. Open a elevated privilege command window, in Windows click Start and type cmd and then right-click on cmd.exe and select Run as Administrator or in Linux open a terminal window and enter sudo -i and your password, and navigate to the folder where you extracted the firmware file's contents.

Then enter these commands manually, one at a time (it's OK to copy/paste them individually, just don't do the whole thing at once):

fastboot oem fb_mode_set
fastboot flash partition gpt.bin
fastboot flash motoboot motoboot.img
fastboot reboot-bootloader
fastboot flash logo logo.bin
fastboot flash boot boot.img
fastboot flash recovery recovery.img
fastboot flash system system.img_sparsechunk.0
fastboot flash system system.img_sparsechunk.1
fastboot flash system system.img_sparsechunk.2
fastboot flash system system.img_sparsechunk.3
fastboot flash modem NON-HLOS.bin
fastboot erase modemst1
fastboot erase modemst2
fastboot flash fsg fsg.mbn
fastboot erase cache
fastboot erase userdata
fastboot oem fb_mode_clear
fastboot reboot

If ANY step fails, or gives any response other than OKAY, check the command and try again. In some cases the modems will need to be done be done 2-3 times. If you get a "Preflash validation error" on the partition table (gpt.bin) it is OK to skip that file (ONLY if you get that error), but you must do each step after that.

The first boot on Marshmallow can take a long time, give it at least 20 minutes after the final reboot to come up to the setup wizard.

This should bring the modem/radio firmware in line with the boot image and the hardware radio and allow you to get normal service again.

Good luck!

1
  • @JaiminSutariya Awesome! Glad I could help... Sorry for all the questions but it was the only way to get to the solution.
    – acejavelin
    Commented Apr 5, 2017 at 18:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .