4

Been using the Alpha version of CM7 for the Samsung T989 (T-Mobile Galaxy S II) for over 2 weeks now. Seems like when I rebooted it today it managed to corrupt the data partition.

Symptoms: -Normal starts loop just after the kernel screen. -CWM boots and works -ODIN boots. -CWM crashes when doing factory reset or restoring the data partition of a backup or formatting the data partition

This happened to me 2 days after installing CM7, the same version I'm still using. I was similarly stuck, but then I tried restoring my nandroid backup and eventually I could re-apply the CM7 zip and the phone started fine to a blank android.

Is there a way to solve this issue with my partitions? I am not too comfortable with re-partitioning it because I'm aware this can damage the boot sectors and brick it quickly if I don't do it just right.

Advice?

1

Try doing a data wipe and wipe the cache as well. I would then reinstall the CM7 package on the device.

If the issue is specifically with CWM crashing, it could be because the partitions are sizes that CWM doesn't support. I had an issue like that with my Nook Color. I have a nerwer model and the data partitions were 5GB and the media partition was 2GB, the older versions had it reversed. I found a script that someone already created to put the partitions back to the old format and CWM worked fine after that.

Now, I am taking a shot in the dark here on this, as I do not have that device, nor have I really read anything about it or the issue you are describing.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.