0

I've edited the question title and I'm adding this prefix. The problem of my computer (via ADB) not seeing my phone at all seemed to entirely depend on how I was physically connecting the phone to the computer. Via three different USB-A (old big rectangular plugs, computer side) to USB-C (phone) cables, the phone remained invisible. When I plug any of the same USB-A to USB-C cables into an old USB "extension" cable (USB-A female on one end, male on the computer end), everything works fine.


I'm trying to get my ZTE Axon 7 to connect to an Ubuntu 16.04 installation via ADB. I've actually done this before, but for whatever reason it simply does not work now.

The relevant output from lsusb is

Bus 003 Device 032: ID 19d2:0306 ZTE WCDMA Technologies MSM 

I've tried the phone in every USB connection mode it offers, all with the same non-operational result.

From the Ubuntu machine, I run

adb kill-server
adb start-server
adb devices -l

The phone is plugged in via its stock cable (and I've tried two others). Running adb devices lists nothing.

The "USB Debugging" option is enabled on the phone. I've restarted the phone multiple times.

Again, I've done this before, and it worked without incident. I'm probably just missing some important step.

I'd connect with MTP if I could, because all I need to do is transfer files, but it doesn't work; mtpfs just hangs indefinitely when I start it. I've read that Ubuntu should be able to deal with MTP without any additional tools, but I have no idea how that's supposed to work. When I plug the phone in, here's what I get in kern.log:

Apr  5 23:02:44 turandot kernel: [ 7858.845536] usb 3-2: new SuperSpeed USB device number 34 using xhci_hcd
Apr  5 23:02:44 turandot kernel: [ 7858.862996] usb 3-2: New USB device found, idVendor=19d2, idProduct=0306
Apr  5 23:02:44 turandot kernel: [ 7858.863005] usb 3-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Apr  5 23:02:44 turandot kernel: [ 7858.863009] usb 3-2: Product: Android
Apr  5 23:02:44 turandot kernel: [ 7858.863013] usb 3-2: Manufacturer: Android
Apr  5 23:02:44 turandot kernel: [ 7858.863016] usb 3-2: SerialNumber: 293baffd
Apr  5 23:02:44 turandot kernel: [ 7858.864244] usb 3-2: Enable of device-initiated U1 failed.
Apr  5 23:02:44 turandot kernel: [ 7858.864594] usb 3-2: Enable of device-initiated U2 failed.

I've tried ADB with my older Moto X Pure, and ADB can connect to it without issue from the same Ubuntu laptop.

I'm really not sure what the next step is; I've followed the exact same notes I used last time I transferred files to the Axon but it absolutely doesn't work now.

edit — well progress. I had in the past been plugging my phone into the computer via a fairly old USB "extension" cable. Today I was plugging the USB-C to USB-A cable directly into the laptop. When I returned to the old extension cable, the phone was recognized. I'll leave the question here because maybe somebody knows why that might happen.

1

I found following this article https://www.howtoforge.com/tutorial/how-to-connect-your-android-device-on-linux/ to setup your linux installation for mtpfs file system. In a nutshell:

1) On your Ubuntu Linux: sudo apt-get install mtpfs sudo mtpfs -o allow_other ~/mnt 2) On your phone: Under Settings -> Connect to a PC, select "Media Device MTP"

This should immediately allow connection (with whatever cable in usb) to your Ubuntu 16.04 (which I use with my Axion ZTE 7 Mini) and allow access to phones internal storage and SD storage with file manager.

  • Does mtp_connect actually work for you? For me, it sits there for a long time and then fails. – Pointy Jun 1 '17 at 19:19
  • Oh wait no it did seem to work. Really slow though. Nevertheless, thanks very much. – Pointy Jun 1 '17 at 19:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.