3

My phone has two sims both with large data caps that I'd like to use. I use my phone as a wireless access point for my laptop.

To switch between SIM 1/2 for data, I have to go to

settings-->wireless networks --> more-->mobile networks

and then set the network mode. The one which I wish to use for internet goes to GSM/WCDMA/LTE auto and the other 'just phone calls' I switch to GSM only. I then go to

settings-->wireless networks --> dual sim cards --> data network

and set "Sim card to use" to sim 1 or 2.

This seems to work fine for access data on the phone. However, when I'm connected on my laptop via the hotspot, I only get internet access on SIM 2. With SIM 1, the computer wifi connects but says "no internet access". When I run the windows troubleshooting wizard, it says "failed to find DNS". I set my DNS to 8.8.8.8... but no joy.

I've also tried to connect via macs and Linux boxes with the same result. I think that the issue is in the droid.

Any suggestions? Thanks in advance :-)

1

Solution 2:

Please Run "ipconfig" command in your Command Prompt. After running command you can find information's like "IPv4 Address", "Default Gateway", Subnet Mask, etc. Use those values in respective fields of :

Open Network and Sharing Center-->Change Adapter Settings-->Right click on "Wireless Network Connection"-->Properties-->Select "Internet Protocol Version 4(TCP/IPv4)"-->Select Radio Button for 1)Use the following IP Address, 2)Use the following DNS Server automatically --> and finally "Ok"

Field to be filled: 1)IP Address 2)Subnet Mask 3)Default Gateway 4)Preferred DNS Server

NB:"Default Gateway" need to given as "Preferred DNS Server"

Best Regards

1

I have the same issue. My phone is now three years old and the problem remains even after upgrading from kitkat to lolipop.

From allbthe tests I did it's an Android issue. If I remove the SIM where hotspot is working and reboot the phone I can switch the hotspot to the other SIM.

1

It's an android problem and there is an easy fix. Connect to the 2nd sim start the hotspot then you will be connected but without internet. Now let the hotspot running and switch off data and on again....Voila... worked for me

0

Solution 1:

In laptop please modify wifi settings as follows:

Open Network and Sharing Center-->Change Adapter Settings-->Right click on "Wireless Network Connection"-->Properties-->Select "Internet Protocol Version 4(TCP/IPv4)"-->Select Radio Button for 1)Obtain an IP address automatically, 2)Obtain an DNS Server automatically --> Ok

NB:Please make a note of values currently in "Internet Protocol Version 4(TCP/IPv4)".Attaching Screen shot of Selection

Best Regards

  • Thanks Sreerag. Alas, that was the first thing that I tried. It didn't work. – Damien Sawyer Apr 11 '17 at 9:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.