20

In previous versions of Android, when my phone battery was going down quickly I could open an app like OS Monitor, see what process is using a lot CPU (often it was Evernote or Maps.me), and then kill that process.

However, OS Monitor and similar apps aren't working with Android 7 anymore, I guess due to some change in the system.

So I'm wondering, is there a way that would allow me to see what's consuming CPU in the latest version of Android?

6
  • In developer options, you can see the "Running Services" which will show all services with their RAM usage. Commented Apr 11, 2017 at 15:30
  • 1
    Thanks, but is it possible to also get it to display the CPU usage too?
    – laurent
    Commented Apr 11, 2017 at 15:37
  • Have you tried other alternatives like system monitor, I think they pretty much do the same job Commented Apr 11, 2017 at 15:47
  • @xavier, yes I've tried a few of them, but couldn't find one that was working.
    – laurent
    Commented Apr 11, 2017 at 15:51
  • Thats okay its only I am not using android 7 now, could have tested a few, but will check in my emulator for compatibility Commented Apr 11, 2017 at 15:52

2 Answers 2

8

You can use adb shell /system/bin/dumpsys cpuinfo.
This should also work with Oreo.

4

(Edited - confirmed also not working on 7.1.1 unrooted.)

This should work on any Android version, but you might find the output a bit unfriendly:

  1. Install and launch Termux (Google Play)
  2. Open Termux and run apt install top
  3. Run top
7
  • This definitely doesn't work on 4.4 or lower. Because Termux doesn't support 4.4 and below.
    – iBug
    Commented May 1, 2017 at 23:51
  • 4
    Thanks, but it doesn't work either, it only shows two processes (bash and top). I guess low level access to processes is now disabled in new Android version so no app can view them.
    – laurent
    Commented May 2, 2017 at 8:31
  • You can use"su" command before "top".
    – user219263
    Commented May 3, 2017 at 23:09
  • 1
    This requires root?
    – roxan
    Commented Jun 5, 2017 at 4:39
  • 2
    same problem, only shows two processes with 0% cpu usage, while my phone is seriously overheated. su command doesn't work as well :-(
    – Tomas
    Commented Jul 6, 2018 at 11:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .