1

I know it's a relatively new and unstable application but I figured if anyone has suffered through the issue and solved it then they can help me too.

So Anbox doesn't come pre-installed with Google play store and not even a Package Installer so only way to install applications is through Android Debug Bridge aka ADB

adb install /path/to/file.apk

would result in installing the application in Anbox. which worked for me for installing QuickPic and Snapseed

but it failed in installing Opera Mini and WPS Office giving the Following error

Input:

adb install /home/sumeet/Downloads/opera.apk

Output:

* daemon not running. starting it now on port 5037 *
* daemon started successfully *
30103 KB/s (4597754 bytes in 0.149s)
Failure [INSTALL_FAILED_NO_MATCHING_ABIS: Failed to extract native libraries, res=-113]

So my question is this, is it An Anbox problem, or Ubuntu Problem or ADB problem that can be fixed? and since it's essentially just an android emulator running on top of Linux, How can I fix this?

3

Let's take a look at the error message again:

Failure [INSTALL_FAILED_NO_MATCHING_ABIS: Failed to extract native libraries, res=-113]

This means that the app in question uses native C/C++ libraries, but the APK doesn't include that library compiled for the CPU architerchture of the the target device. Unlike Java, C/C++ code is not cross-platform, nor is it cross-architecture.

Some apps have different APKs for the different CPU architectures.

But, bottom line, this is the app developer's fault, not yours.

Original Source

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.